Skill Test : OSPFv2 Multiarea Adjacency

ospf_cluster

OSPFV2 Multi area Topology

OSPFv2 Configuration Command Line :  

R1 command line:

R1(config)interface GigabitEthernet0/0
R1(config-if) ip address 10.1.1.1 255.255.255.0
R1(config) interface GigabitEthernet0/1
R1(config-if) ip address 10.1.2.1 255.255.255.0
R1(config)#int s0/3/0
R1(config-if)#ip address 192.168.10.2 255.255.255.252
R1(config-if)#no shut

Enable OSPF on R1 :

R1(config)#router ospf 10
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.1.1.1 0.0.0.0 area 1
R1(config-router)#network 10.1.2.1 0.0.0.0 area 1
R1(config-router)#network 192.168.10.2 0.0.0.0 area 0
R1(config-router)#

R2 command line:

Router(config)#hostname R2
R2(config)#int s0/3/0
R2(config-if)#ip address 192.168.10.1 255.255.255.252
R2(config-if)#clock rate 2000000
R2(config-if)#no shut
R2(config)#interface GigabitEthernet0/0
R2(config)#ip address 10.2.1.1 255.255.255.0
R2(config)#int s0/3/1
R2(config-if)#ip address 192.168.10.5 255.255.255.252
R2(config-if)#clock rate 2000000
R2(config-if)#no shut

Configuration of R2 as ABR:

R2(config)#router ospf 10

R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#network 192.168.10.4 0.0.0.3 area 0
R2(config-router)#network 10.2.1.0 0.0.0.255 area 0

R3 command line:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#
R3(config)#int g0/0
R3(config-if)#ip address 192.168.2.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#
R3(config)#int g0/1
R3(config-if)#ip address 192.168.1.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#
R3(config)#int s0/3/1
R3(config-if)#ip address 192.168.10.6 255.255.255.252
R3(config-if)#no shut

Enable OSPF on R3:
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.2.1 0.0.0.0 area 2
R3(config-router)#network 192.168.1.1 0.0.0.0 area 2
R3(config-router)#network 192.168.10.6 0.0.0.0 area 0
R3(config-router)#
Verfication command line:

R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:31 192.168.10.1 Serial0/3/0
R1#
R1#
R1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 250 0x80000002 0x000ec0 2
3.3.3.3 3.3.3.3 213 0x80000002 0x0006b0 2
2.2.2.2 2.2.2.2 184 0x80000005 0x009c77 5

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 443 0x80000001 0x00db72
10.1.2.0 1.1.1.1 443 0x80000002 0x00ce7d
192.168.2.0 3.3.3.3 357 0x80000001 0x007175
192.168.1.0 3.3.3.3 357 0x80000002 0x007a6c

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 448 0x80000003 0x008f8f 2

Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.10.0 1.1.1.1 438 0x80000001 0x00bbee
192.168.10.4 1.1.1.1 215 0x80000002 0x001451
192.168.2.0 1.1.1.1 205 0x80000003 0x00aebd
192.168.1.0 1.1.1.1 205 0x80000004 0x00b7b4
10.2.1.0 1.1.1.1 179 0x80000005 0x004abe
R1#show ip protocols
R1#show ip route
R1#show ip ospf interface

R2#show ip protocols

Routing Protocol is “ospf 10”
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 2.2.2.2
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
192.168.10.0 0.0.0.3 area 0
192.168.10.4 0.0.0.3 area 0
10.2.1.0 0.0.0.255 area 0
Routing Information Sources:
Gateway Distance Last Update
1.1.1.1 110 00:05:21
2.2.2.2 110 00:04:15
3.3.3.3 110 00:04:44
Distance: (default is 110)
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ – 00:00:38 192.168.10.2 Serial0/3/0
3.3.3.3 0 FULL/ – 00:00:35 192.168.10.6 Serial0/3/1
R2#
R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:35 192.168.10.5 Serial0/3/1
R3#
Area 1 cluster 0 OSPF enable :

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 10
Router(config-router)#router-id 5.5.5.5
Router(config-router)#network 10.1.1.2 0.0.0.0 area 1
Router(config-router)#exit
Router(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 10
Router(config-router)#router-id 6.6.6.6
Router(config-router)#network 10.1.2.2 0.0.0.0 area 1
Router(config-router)

Area 2 cluster 1 OSPF enable :
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 10
Router(config-router)#router-id 7.7.7.7
Router(config-router)#network 192.168.2.2 0.0.0.0 area 2
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 10
Router(config-router)#router-id 9.9.9.9
Router(config-router)#network 192.168.1.2 0.0.0.0 area 2
Router(config-router)#
01:10:17: %OSPF-5-ADJCHG: Process 10, Nbr 3.3.3.3 on GigabitEthernet0/1 from LOADING to FULL, Loading Done

Area 0 cluster 2 OSPF enable :

Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#router ospf 10
Router(config-router)#router-id 4.4.4.4
Router(config-router)#network 10.2.1.2 0.0.0.0 area 0
Router(config-router)#
01:06:13: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0 from LOADING to FULL, Loading Done

Verification :

R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
4.4.4.4 1 FULL/BDR 00:00:38 10.2.1.2 GigabitEthernet0/0
1.1.1.1 0 FULL/ – 00:00:30 192.168.10.2 Serial0/3/0
3.3.3.3 0 FULL/ – 00:00:30 192.168.10.6 Serial0/3/1
R2#

R3#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:36 192.168.10.5 Serial0/3/1
7.7.7.7 1 FULL/BDR 00:00:37 192.168.2.2 GigabitEthernet0/0
9.9.9.9 1 FULL/BDR 00:00:35 192.168.1.2 GigabitEthernet0/1
R3#

R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:32 192.168.10.1 Serial0/3/0
5.5.5.5 1 FULL/BDR 00:00:33 10.1.1.2 GigabitEthernet0/0
6.6.6.6 1 FULL/BDR 00:00:34 10.1.2.2 GigabitEthernet0/1
R1#

Thank you

Momataj Momo

Skill Test : EIGRP Configuration

EIGRP

Configuration Command Line: 

Router(config)#hostname R1
R1(config)#
R1(config)#int g0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#exit
R1(config)#int s0/3/0
R1(config-if)#ip address 172.16.3.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/0, changed state to down
R1(config-if)#
R1(config-if)#
R1(config)#int s0/3/1
R1(config-if)#ip address 192.168.10.6 255.255.255.252
R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/1, changed state to down
R1(config-if)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#

R2(config)#int g0/0
R2(config-if)#ip address 172.16.2.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config-if)#

R2(config-if)#exit
R2(config)#int s0/3/0
R2(config-if)#ip address 172.16.3.2 255.255.255.252
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

R2(config-if)#

R2(config)#int s0/3/1
R2(config-if)#ip address 192.168.10.9 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/1, changed state to down
R2(config-if)#exit
R2(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#

R3(config)#int g0/0
R3(config-if)#ip address 192.168.1.1 255.255.255.0
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R3(config-if)#

R3(config)#int s0/3/1
R3(config-if)#ip address 192.168.10.10 255.255.255.252
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/1, changed state to up

R3(config-if)#exit
R3(config)#

R3(config)#int s0/3/0
R3(config-if)#ip address 192.168.10.5 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

R3(config-if)#

EIGRP Command Line: 

R1(config)#router eigrp 10
R1(config-router)#network 172.16.1.0 0.0.0.255
R1(config-router)#network 192.16.3.0 0.0.0.3
R1(config-router)#network 192.168.10.4 0.0.0.3
R1(config-router)#
R2(config)#router eigrp 10
R2(config-router)#network 172.16.2.0 0.0.0.255
R2(config-router)#network 172.16.3.0 0.0.0.3
R2(config-router)#network 172.168.10.8 0.0.0.3
R2(config-router)#
R3(config)#router eigrp 10
R3(config-router)#network 192.168.10.8 0.0.0.3
R3(config-router)#network 192.168.10.4 0.0.0.3
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 192.168.10.6 (Serial0/3/0) is up: new adjacency

R3(config-router)#network 192.168.1.0 0.0.0.255
R3(config-router)#

Thank you

Momataj Momo