Skill Test : Configuration of Frame Relay

Untitled

Part 1 Configure Frame-Relay:

R1:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int s0/1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shut

R1(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R1(config-if)#

R1(config-if)#exit
R2:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int s0/1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R2(config-if)#exit
R2(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int s0/1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R3(config-if)#exit

Part 2: Configure Frame Relay Point-to-Point Subinterfaces
R1(config)#int s0/1/0.102 point
R1(config)#int s0/1/0.102 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.102, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.102, changed state to up

R1(config-subif)#ip address 10.1.1.1 255.255.255.252
R1(config-subif)#bandwidth 64
R1(config-subif)#frame-relay interface-dlci 102
R1(config-subif)#exit

R1(config)#int s0/1/0.103 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.103, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.103, changed state to up

R1(config-subif)#ip address 10.1.3.2 255.255.255.252
R1(config-subif)#bandwidth 64
R1(config-subif)#frame-relay interface-dlci 103
R1(config-subif)#exit
R1(config)#

R2(config)#int s0/1/0.201 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.201, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.201, changed state to up

R2(config-subif)#ip address 10.1.1.2 255.255.255.252
R2(config-subif)#bandwidth 64
R2(config-subif)#frame-relay interface-dlci 201
R2(config-subif)#exit
R2(config)#

R2(config)#int s0/1/0.203 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.203, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.203, changed state to up

R2(config-subif)#ip address 10.1.2.1 255.255.255.252
R2(config-subif)#bandwidth 64
R2(config-subif)#frame-relay interface-dlci 203
R2(config-subif)#exit
R2(config)#

R3(config)#int s0/1/0.301 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.301, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.301, changed state to up

R3(config-subif)#ip address 10.1.3.1 255.255.255.252
R3(config-subif)#bandwidth 64
R3(config-subif)#frame-relay interface-dlci 301
R3(config-subif)#exit
R3(config)#

R3(config)#int s0/1/0.302 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.302, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.302, changed state to up

R3(config-subif)#ip address 10.1.2.2 255.255.255.252
R3(config-subif)#bandwidth 64
R3(config-subif)#frame-relay interface-dlci 302
R3(config-subif)#exit
R3(config)#
Router Configuration :

R1(config)#int g0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config)#int g0/0
R2(config-if)#ip address 192.168.30.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config-if)#exit
R2(config)#

R3(config)#int s0/1/1
R3(config-if)#ip address 209.165.200.225 255.255.255.224
R3(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
R3(config-if)#
R3(config-if)#clock rate 64000
R3(config-if)#exit
R3(config)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ISP
ISP(config)#int s0/3/0
ISP(config-if)#ip address 209.165.200.226 255.255.255.224
ISP(config-if)#no shut

ISP(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

ISP(config-if)#

ISP(config)#int g0/0
ISP(config-if)#ip address 209.165.200.1 255.255.255.252
ISP(config-if)#no shut

ISP(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

ISP(config-if)#
R1(config-if)#router eigrp 1
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#network 10.1.3.0 0.0.0.3
R1(config-router)#network 192.168.10.0 0.0.0.255
R1(config-router)#exit
R1(config)#
R2(config)#router eigrp 1
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#network 10.1.2.0 0.0.0.3
R2(config-router)#network 192.168.30.0 0.0.0.255
R2(config-router)#exit
R2(config)#

R3(config)#router eigrp 1
R3(config-router)#network 10.1.3.0 0.0.0.3
R3(config-router)#network 10.1.2.0 0.0.0.3
R3(config-router)#network 209.165.200.0 0.0.0.31
R3(config-router)#

Thank you

Momataj Momo

OSPFV2 Multi area Technology ( Configuration )

OSPFV2 Multi area configuration

OSPFV2 Multi area configuration

Router R1:

R1(config)#: interface GigabitEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config)#: interface GigabitEthernet0/1
R1(config-if)#ip address 10.1.2.1 255.255.255.0

R1(config)#: interface Serial0/3/0
R1(config-if)#ip address 192.168.10.1 255.255.255.252
R1(config-if)#clock rate 64000

OSPFV2 Configuration Command:

R1(config)#router ospf 10
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.1.1.1 0.0.0.0 area 1
R1(config-router)#network 10.1.2.1 0.0.0.0 area 1
R1(config-router)#network 192.168.10.1 0.0.0.0 area 0
R1(config-router)#

Summarizing OSPF: 

R1(config)#router ospf 10

R1(config-router)#area 1 range 10.1.0.0 255.255.252.0
Router R2:

R2(config)#interface Serial0/3/0
R2(config-if)#ip address 192.168.10.2 255.255.255.252
R2(config)#

R2(config)#interface Serial0/3/1
R2(config-if)#ip address 192.168.10.5 255.255.255.252
R2(config-if)clock rate 64000

R2(config)#router ospf 10
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#network 192.168.10.4 0.0.0.3 area 0
R2(config-router)#
Router R3:

R3(config)#interface GigabitEthernet0/0
R3(config-if)# ip address 192.168.1.1 255.255.255.0

R3(config)#interface GigabitEthernet0/1
R3(config-if)# ip address 192.168.2.1 255.255.255.0
R3(config)#interface Serial0/3/1
R3(config-if)#ip address 192.168.10.6 255.255.255.252
Router(config)#hostname R3
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.10.6 0.0.0.0 area 0
R3(config-router)#network 192.168.1.1 0.0.0.0 area 2

R3(config-router)#network 192.168.2.1 0.0.0.0 area 2
R3(config-router)#end

Summarizing OSPF: 

R2(config)#router ospf 10

R2(config-router)#area 2 range 192.168.0.0 255.255.252.0

Verification and Troubleshooting Command:

R3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:38 192.168.10.5 Serial0/3/1
R3#
R3#
R3#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 1.1.1.1 [128] via 192.168.10.5, Serial0/3/1, ABR, Area 0, SPF 128
R3#
R1#show ip ospf interface

R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:30 192.168.10.2 Serial0/3/0
R1#

R1#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 3.3.3.3 [128] via 192.168.10.2, Serial0/3/0, ABR, Area 0, SPF 128
R1#
R1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 239 0x80000002 0x00ffcf 2
2.2.2.2 2.2.2.2 164 0x80000004 0x00bc75 4
3.3.3.3 3.3.3.3 144 0x80000003 0x0004b1 2

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 284 0x80000001 0x00db72
10.1.2.0 1.1.1.1 284 0x80000002 0x00ce7d
192.168.1.0 3.3.3.3 139 0x80000001 0x007c6b
192.168.2.0 3.3.3.3 119 0x80000002 0x006f76

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 288 0x80000003 0x008f8f 2

Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.10.0 1.1.1.1 284 0x80000001 0x00bbee
192.168.10.4 1.1.1.1 219 0x80000002 0x001451
192.168.1.0 1.1.1.1 134 0x80000003 0x00b9b3
192.168.2.0 1.1.1.1 114 0x80000004 0x00acbe
R1#

R1#show ip route ospf
O IA 192.168.1.0 [110/129] via 192.168.10.2, 00:04:37, Serial0/3/0
O IA 192.168.2.0 [110/129] via 192.168.10.2, 00:04:17, Serial0/3/0
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O 192.168.10.4 [110/128] via 192.168.10.2, 00:06:03, Serial0/3/0
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ – 00:00:31 192.168.10.1 Serial0/3/0
3.3.3.3 0 FULL/ – 00:00:34 192.168.10.6 Serial0/3/1
R2#

R2#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 1.1.1.1 [64] via 192.168.10.1, Serial0/3/0, ABR, Area 0, SPF 64
i 3.3.3.3 [64] via 192.168.10.6, Serial0/3/1, ABR, Area 0, SPF 64
R2#

R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 304 0x80000002 0x00ffcf 2
2.2.2.2 2.2.2.2 230 0x80000004 0x00bc75 4
3.3.3.3 3.3.3.3 209 0x80000003 0x0004b1 2

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 349 0x80000001 0x00db72
10.1.2.0 1.1.1.1 349 0x80000002 0x00ce7d
192.168.1.0 3.3.3.3 204 0x80000001 0x007c6b
192.168.2.0 3.3.3.3 184 0x80000002 0x006f76
R2#

List of verification command:

R1# show Ip route OSPF
R1#show IP OSPF NEIGHBOR
R1#SHOW IP OSPF
R1#SHOW IP OSPF INTERFACE
R1#SHOW IP PROTOCOLS
R1#SHOW IP OSPF INTERFACE BRIEF
R1#SHOW IP OSPF DATABASE
R1#SHOW IP OSF BORDER-ROUTERS

Summarizing OSPF verification Command:

R3#show ip route ospf

10.0.0.0/22 is subnetted, 1 subnets

O IA 10.1.0.0 [110/129] via 192.168.10.5, 00:00:55, Serial0/3/1

192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks

O 192.168.10.0 [110/128] via 192.168.10.5, 00:01:05, Serial0/3/1

R3#

Thank you

Momataj Momo

Practice Skills Assessment – Packet Tracer (Module One Exam Solution )

You will practice and be assessed on the following skills:

  • Configuration of initial IOS device settings
  • Design and calculation of IPv4 addressing
  • Configuration of IOS device interfaces including IPv4 and IPv6 addressing when appropriate
  • Addressing of network hosts with IPv4 and IPv6 addresses
  • Enhancing device security, including configuration of the secure transport protocol for remote device configuration
  • Configuration of a switch management interface

Requirements by device:

  • Town Hall router:
  • Configuration of initial router settings
  • Interface configuration and IPv4 and IPv6 addressing
  • Device security enhancement or “device hardening”
  • Secure transport for remote configuration connections as covered in the labs.
  • Backup of the configuration file to a TFTP server
  • Administration Switch:
  • Enabling basic remote management by Telnet
  • PC and Server hosts:
  • IPv4 full addressing
  • IPv6 addressing
Skill Test Exam Solution

Fig : Topology (Skill Test Exam Solution)

ccna-1-skill-final-1

Step 1:

Design an IPv4 addressing scheme and complete the Addressing Table based on the following requirements. Use the table above to help you organize your work.

a. Subnet the 192.168.1.0/24 network to provide 30 host addresses per subnet while wasting the fewest addresses.

b. Assign the fourth subnet to the IT Department LAN.

c. Assign the last network host address (the highest) in this subnet to the G0/0 interface on Town Hall.

d. Starting with the fifth subnet, subnet the network again so that the new subnets will provide 14 host addresses per subnet while wasting the fewest addresses.

e. Assign the second of these new 14-host subnets to the Administration LAN.

f. Assign the last network host address (the highest) in the Administration LAN subnet to the G0/1 interface of the Town Hall router.

g. Assign the second to the last address (the second highest) in this subnet to the VLAN 1 interface of the Administration Switch.

h. Configure addresses on the hosts using any of the remaining addresses in their respective subnets.

Step 2: Configure the Town Hall Router.

a. Configure the Town Hall router with all initial configurations that you have learned in the course so far:

· Configure the router hostname: Middle

· Protect device configurations from unauthorized access with the encrypted password.

· Secure all of the ways to access the router using methods covered in the course and labs.

· Newly-entered passwords must have a minimum length of 10 characters.

· Prevent all passwords from being viewed in clear text in device configuration files.

· Configure the router to only accept in-band management connections over the protocol that is more secure than Telnet, as was done in the labs. Use the value 1024 for encryption key strength.

· Configure user authentication for in-band management connections.

b. Configure the two Gigabit Ethernet interfaces using the IPv4 addressing values you calculated and the IPv6 values provided in the addressing table.

· Reconfigure the link local addresses as was practiced in the labs. The IPv6 link-local Interface ID should match the IPv6 unicast Interface ID as is practiced in the labs.

· Document the interfaces in the configuration file.

Step 3: Configure the Administration Switch.

Configure Administration Switch for remote management.

Step 4: Configure and Verify Host Addressing.

a. Use the IPv4 addressing from Step 1 and the IPv6 addressing values provided in the addressing table to configure all host PCs with the correct addressing.

b. Use the router interface link-local addresses as the IPv6 default gateways on the hosts.

c. All hosts should be able to ping each other over IPv4.

Step 5: Backup the Configuration of the Town Hall Router to TFTP.

a. Complete the configuration of the TFTP server using the IPv4 addressing values from Step 1 and the values in the addressing table.

b. Backup the running configuration of Town Hall to the TFTP Server. Use the default file name.

Solution : 

Router>
Router>enable
Router#configure terminal
Router(config)#interface g0/0
Router(config-if)#ip address 192.168.1.126 255.255.255.224
Router(config-if)#description IT Department LAN
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#ip address 192.168.1.158 255.255.255.240
Router(config-if)#description Administration LAN
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ipv6 unicast-routing
Router(config)#interface g0/0
Router(config-if)#ipv6 address 2001:db8:acad:A::1/64
Router(config-if)#ipv6 address FE80::1 link-local
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#ipv6 address 2001:db8:acad:B::1/64
Router(config-if)#ipv6 address FE80::1 link-local
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#
Router(config)#hostname Middle
Middle(config)#Enable secret class12345
Middle(config)#line console 0
Middle(config-line)#password cisconet2014
Middle(config-line)#login
Middle(config-line)#exit
Middle(config)#line vty 0 15
Middle(config-line)#password cisconet2014
Middle(config-line)#login
Middle(config-line)#exit
Middle(config)#line aux 0
Middle(config-line)#password cisconet2014
Middle(config-line)#login
Middle(config-line)#exit
Middle(config)#
Middle(config)#Banner motd “Authorized Access Only”
Middle(config)#security password min-length 10
Middle(config)#service password-encryption
Middle(config)#ip domain-name ccna.net
Middle(config)#username cisco secret cisconet2014
Middle(config)#crypto key generate rsa
The name for the keys will be: Middle.cisco.local
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

Middle(config)#line vty 0 15
Middle(config-line)#login local
Middle(config-line)#transport input ssh
Middle(config-line)#exit
Middle(config)#

—————————————–
Switch1 ip default gateway 192.168.1.158

—————————————–

Reception Host
default gateway FE80::1
default gateway 192.168.1.126

IP address 192.168.1.97/27
IPv6 address 2001:DB8:ACAD:A::FF/64

—————————————–

Operator Host

default gateway FE80::1
default gateway 192.168.1.126

IP address 192.168.1.98/27
IPv6 address 2001:DB8:ACAD:A::15/64

—————————————–

IT Host

default gateway FE80::1
default gateway 192.168.1.158

IP address 192.168.1.145/28
IPv6 address 2001:DB8:ACAD:B::FF/64

—————————————–

SERVER TFTP

default gateway FE80::1
default gateway 192.168.1.158

IP address 192.168.1.146/28
IPv6 address 2001:DB8:ACAD:B::15/64

—————————————–

Backup the Configuration of the Town Hall Router to TFTP.

Middle#copy running-config tftp
Address or name of remote host []? 192.168.1.146
Destination filename [Router-confg]? [Press Enter]

—————————————–

Momataj Momo

 

IPv4 : Variable Length Subnet Masking (VLSM)

A Variable Length Subnet Mask (VLSM):  is a numerical masking sequence, or IP address subset, based on overall network requirements. A VLSM allows a network administrator to use long masks for networks with few hosts and short masks for networks with multiple hosts. A VLSM is used with a VLSM router and must have routing protocol support.
A VLSM is also known as a classless Internet Protocol (IP) address.

VLSM enables you to have more than one mask for a given class of address, albeit a class A, B, or C network number.

VLSM, originally defined in RFC 1812, allows you to apply different subnet masks to the same class address space Classful protocols, such as RIPv1 and IGRP, do not support VLSM. To deploy VLSM requires a routing protocol that is classless—BGP, EIGRP, IS-IS, OSPF, or RIPv2, for instance.

VLSM provides Two major advantages:

  • more efficient use of addressing
  • Ability to perform route summarization

when you perform classful subnetting, all subnets have the same number of hosts because they all use the same subnet mask. This leads to inefficiencies. For example, if you borrow 4 bits on a Class C network, you end up with 14 valid subnets of 14 valid hosts. A serial link to another router only needs 2 hosts, but with classical subnetting, you end up wasting 12 of those hosts. Even with the ability to use NAT and private addresses, where you should never run out of addresses in a network design, you still want to ensure that the IP plan that you create is as efficient as possible.

An efficient addressing scheme using VLSM:

  • Find the largest segment in the area—the segment with the largest number of devices connected to it.
  • Find the appropriate subnet mask for the largest network segment.
  • Write down your subnet numbers to fit your subnet mask.
  • For your smaller segments, take one of these newly created subnets and apply a different, more appropriate, subnet mask to it.
  • Write down your newly subnetted subnets.
  • For even smaller segments, go back to step 4.

Variable Length Subnet Masking (VLSM) is a way of further subnetting a subnet. Using Variable Length Subnet Masking (VLSM) we can allocate IPv4 addresses to the subnets by the exact need. Variable Length Subnet Masking (VLSM) allows us to use more than one subnet mask within the same network address space. If we recollect from the previous lessons, we can divide a network only into subnets with equal number of IPv4 addresses. Variable Length Subnet Masking (VLSM) allows to create subnets from a single network with unequal number of IPv4 addresses.

Example: We want to divide 192.168.10.0, which is a Class C network, into four networks, each with unequal number of IPv4 addresses requirements as shown below.

Subnet A : 126 IPv4 Addresses.
Subnet B : 62 IPv4 Addresses.
Subnet C : 30 IPv4 Addresses.
Subnet D : 30 IPv4 Addresses.

This type of division is not possible as described in previous lessons, since it divide the network equally, but is possible with Variable Length Subnet Masking (VLSM).

Original Network (Network to be subnetted) – 192.168.10.0/24

 

Variable Length Subnet Masking (VLSM) – First Division
Divide the two networks equally with 128 IPv4 addresses (126 usable IPv4 addresses) in each network using 255.255.255.128 subnet mask (192.168.10.0/25).

We will get two subnets each with 128 IPv4 addresses (126 usable IPv4 addresses).

1) 192.168.10.0/25, which can be represented in binaries as below.

11000000.10101000.00001010.00000000
11111111.11111111.11111111.10000000

2) 192.168.10.128/25, which can be represented in binaries as below.

11000000.10101000.00001010.10000000
11111111.11111111.11111111.10000000

Variable Length Subnet Masking (VLSM)- Second Division
Divide second subnet (192.168.10.128/25) we got from the first division again into two Networks, each with 64 IP Addresses (62 usable IPv4 addresses) using 255.255.255.192 subnet mask.

We will get two subnets each with 64 IPv4 addresses (62 usable IPv4 addresses).

1) 192.168.10.128/26, which can be represented in binaries as below.

11000000.10101000.00001010.10000000
11111111.11111111.11111111.11000000

2) 192.168.10.192/26

11000000.10101000.00001010.11 000000
11111111.11111111.11111111.11000000

Variable Length Subnet Masking (VLSM) – Third Division
Divide 192.168.10.192/26 Network again into two Networks, each with 32 IPv4 addresses (30 usable IPv4 addresses) using 255.255.255.224 subnet mask

We will get two subnets each with 32 IPv4 addresses (30 usable IPv4 addresses).

1) 192.168.10.192/27, which can be represented in binaries as below.

11000000.10101000.00001010.11000000
11111111.11111111.11111111.11100000

2) 192.168.10.224/27, which can be represented in binaries as below.

11000000.10101000.00001010.11100000
11111111.11111111.11111111.11100000

Now we have split the 192.168.10.0/24 network into four subnets using Variable Length Subnet Masking (VLSM), with unequal number of IPv4 addresses as shown below. Also note that when you divide a network using Variable Length Subnet Masking (VLSM), the subnet masks are also different.

1) 192.168.10.0 – 255.255.255.128 (126 (128-2) usable IPv4 addresses)
2) 192.168.10.128 – 255.255.255.192 (62 (64-2) usable IPv4 addresses)
3) 192.168.10.192 – 255.255.255.224 (30 (32-2) usable IPv4 addresses)
4) 192.168.10.224 – 255.255.255.224 (30 (32-2) usable IPv4 addresses)

Calculation of VLSM:

The step of necessary  1. In case of VLSM , network bit borrow host bit from right side of host bits. 2. We can find out how many host exists in network . VLSM mainly divided subnet into the subnet.

Example 1: 172.16.32.0/20. Number of user group are 500, 10 , 5 and 2. It’s needed 4 network. 

Solution:  172.16.32.0/20

172.16.00100000.00000000

user group 500 = 29   = 512 = 9 host bits required 

First step: 172.16.0010 | 000 | 0.00000000

Network bits  |          | host bits                                  ( 000, 001,010,011,100,101)

               172.16.32.0/23 – 500 hosts

2nd step: 172.16.0010 | 001 | 0.00000000 /23

               172.16.34.0/23

step 3: Next user group 10= 24   = 16

 172.16.0010 | 001 0.0000 | 0000

             172.16.34.0 /28

Step 4: for user group 5= 23   = 8

           172.16.0010 001| 0.0001 0 | 000

            172.16.34.16/29

step 5: for user group 2= 22  = 4

     172.16.0010 001| 0.0001 1 0 | 00

      172.16.34.24/30

Short Cut Method for VLSM:

For 2 host , need 4 bits because we need to cancel 2 usable host bits. and for find out broadcast address host bits all will be ‘1’ and we will consider highest number of user first.

 

Network Address

Broadcast Address

500 host = 29

               = 512

172.16.32.0/23

172.16.33.255/23

 

10 host =24

              =16      

172.16.34.0 /28

172.16.34.15/28

5 host =23

              = 8

2 host = 22 = 4                                          

172.16.34.16/29

172.16.34.24/30

172.16.34.23/29

172.16.34.27/30

 Example 2: 172.16.128.0/17 , user group are 1000, 1000, 50 , 100, 2, 2

 

Network Address

Broadcast Address

1000 host = 210

               = 1024

172.16.128.0/22

172.16.131.255/22

 

1000 host = 210

               = 1024

172.16.132.0 /22

172.16.135.255/22

100 host = 27

               = 128

172.16.136.0/25

172.16.136.127/25

50 host = 26

               = 64 (64-1=63 host)

172.16.136.128/26

172.16.136.191/26 (128+63=191 host)

2 host = 22

               = 4 (n-1) bit added

172.16.136.192/30

CIDR (32-2 =30)

172.16.136.195 /30 (192+3 =195)

2 host = 22

               = 4 (n-1) bit added

172.16.136.196/30

172.16.136.199/30

 

 

Thank you

Momataj Momo