General information about Routers and Routing

Router Memory :

Similar yet different from a regular computer, the router has different kinds of memory ROM, Flash, NVRAM, and SDRAM which all have different functions:

  • ROM – POST, Bootstrap, and ROMMON
  • Flash – IOS
  • NVRAM – Configuration File
  • SDRAM – Running-Config, Routing Table, IOS (everything is loaded and executed from RAM)

The router is a computer but it does not have a traditional hard drive to store files and the operating system, this is accomplished in Flash memory and NVRAM memory.

Router Bootup Process:

  1. POSTROM memory,
  2. BootstrapROM memory,
  3. Load the IOS – the router has an ordered routine for loading the IOS

    1. Flash Memory – the IOS is typically loaded from Flash memory
    2. TFTP – if there is no IOS in Flash, the router will search for a network TFTP server,
    3. ROM – if there is no IOS found, the router defaults to a recovery IOS called Rommon,
  4. Load the Startup-Configthe router has an ordered routine for loading the startup-config file

    1. NVRAM memory – the startup-config file is typically loaded from NVRAM memory
    2. TFTP – if there is no config file in NVRAM, the router will search for a network TFTP server,
    3. Setup-Mode – if there is no configuration file found, the router defaults to setup-mode

The Router’s Purpose:

The router’s purpose or function is to find the best path (route) and switch out of the correct interface. The router will make the decision of the “best path” by first determining the destination network, and second by consulting its routing table.

Static Routing and Dynamic Routing:

Static routing is a good choice for networks that: never change, are small in size or have only one router, or have only one way out of the network.

Dynamic routing is a good choice if a network has multiple routers, is part of a larger network, or if the network changes frequently.

For example, in a situation where the network changes, with a dynamic routing protocol if a network goes down, the routers will inform each other automatically through the routing protocol, and the route will be removed from the routing table; with static routing, if a network goes down, an administrator will have to go in and remove the the static route manually.

Different types of interior gateway routing protocols: RIPv1, RIPv2, EIGRP, and OSPF.

Routed Protocols
TCP/IP
IPX/SPX (Novell – no longer in use)
Apple Talk (Apple – no longer in use)

Routing Protocols
RIP v1 – interior gateway protocol, IETF – RFC1058, open standard
RIP v2 – interior gateway protocol, IETF, open standard
EIGRP – interior gateway protocol, Cisco proprietary
OSPF – interior gateway protocol, IETF, open standard
ISIS – interior gateway protocol
BGP – exterior gateway protocol
Interior Gateway Routing Protocol Types
Distance Vector     Link State  
RIP v1 OSPF (VLSM/CIDR)
RIP v2 (VLSM/CIDR)

ISIS (VLSM/CIDR)

 EIGRP (VLSM/CIDR)

Thank you

Momataj Momo

Advertisements

CCNA 1 R&S ITN v5.0 Chapter – 6 Skill Assessment – Packet Tracer

 

ccna-1-chapter-6-skill-assessment

                                                                          Skill Test  Question

 

Solutions:

Exam solved

 Science Router Configuration

Science>enable
Science#configure terminal
Science(config)#enable secret cisco
 
Science(config)#line console 0
Science(config-line)#password cisco
Science(config-line)#login
Science(config-line)#exit
 
Science(config)#line vty 0 4
Science(config-line)#password cisco
Science(config-line)#login
Science(config-line)#exit
 
Science(config)#line aux 0
Science(config-line)#password cisco
Science(config-line)#login
Science(config-line)#exit
 
Science(config)#service password-encryption
 
Science(config)#banner motd “Authorized Personnel Only”
 
Science(config)#interface g0/0
Science(config-if)#ip address 172.16.5.1 255.255.255.0
Science(config-if)#no shutdown
Science(config-if)#description Bio LAN
Science(config-if)#exit
 
Science(config)#interface g0/1
Science(config-if)#ip address 192.168.5.1 255.255.255.0
Science(config-if)#no shutdown
Science(config-if)#description Phys LAN
Science(config-if)#end
Science#write
Building configuration…
[OK]

Bio Switch Configuration

Switch>enable
Switch#configure terminal
Switch(config)#hostname Bio
Bio(config)#enable secret class
 
Bio(config)#line console 0
Bio(config-line)#password cisco
Bio(config-line)#login
Bio(config-line)#exit
 
Bio(config)#line vty 0 4
Bio(config-line)#password cisco
Bio(config-line)#login
Bio(config-line)#exit
Bio(config)#service password-encryption
 
Bio(config)#banner motd “Authorized Personnel Only”
 
Bio(config)#interface vlan 1
Bio(config-if)#ip address 172.16.5.2 255.255.255.0
Bio(config-if)#no shutdown
Bio(config-if)#description Bio – Science LAN
Bio(config-if)#exit
Bio(config)#ip default-gateway 172.16.5.1
Bio(config)#end
Bio#write
Building configuration…
[OK]

Phys Switch Configuration

Switch>enable
Switch#configure terminal
Switch(config)#hostname Phys
Phys(config)#enable secret class
 
Phys(config)#line console 0
Phys(config-line)#password cisco
Phys(config-line)#login
Phys(config-line)#exit
 
Phys(config)#line vty 0 4
Phys(config-line)#password cisco
Phys(config-line)#login
Phys(config-line)#exit
 
Phys(config)#service password-encryption
 
Phys(config)#banner motd “Authorized Personnel Only”
 
Phys(config)#interface vlan 1
Phys(config-if)#ip address 192.168.5.252 255.255.255.0
Phys(config-if)#no shutdown
Phys(config-if)#description Phys – Science LAN
Phys(config-if)#exit
Phys(config)#ip default-gateway 192.168.5.1
Phys(config)#end
Phys#write
Building configuration…
[OK]
 
 

Bio 1

172.16.5.10
255.255.255.0
172.16.5.1

Bio 2

172.16.5.11
255.255.255.0
172.16.5.1

Phys 1

192.168.5.10
255.255.255.0
192.168.5.1

Phys 2

192.168.5.11
255.255.255.0
192.168.5.1
 
 
 Thank you
Momataj Momo

 

 

 

 
 
 
 
 
 
 
 
 
 

Skill Test : Practical – 2 Static Router Configuration

stastic router

Topology : Statics Router

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#Hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown

R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit

R1(config)#interface serial 0/0
R1(config-if)#ip address 20.0.0.1 255.0.0.0
R1(
R1(config-if)#no shutdown
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 6400
R1(config-if)#exit
R1(config)#
R1(config-if)#exit

Router>en
Router#config
Router(config)#Hostname R2
Configuring from terminal, memory, or network [terminal]? t
Enter configuration commands, one per line. End with CNTL/Z.

R2(config)#interface serial 0/0
R2(config-if)#ip address 20.0.0.5 255.0.0.0
R2(config-if)#no shutdown
R2(config-if)#exit
r2(config)#interface serial 0/1
r2(config-if)#ip address 30.0.0.1 255.0.0.0
r2(config-if)#no shutdown
r2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1, changed state to up
r2(config-if)#exit
r2(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to up

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#interface fastethernet 0/0
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#clock rate 64000
R3(config-if)#bandwidth 6400
R3(config-if)#
R3(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed state to up

R3#

R3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#exit
R3(config)#

IP Route Configration :

R1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0
C 20.0.0.0/8 is directly connected, Serial0/0

R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip route 30.0.0.0 255.0.0.0 20.0.0.5
R1(config)#ip route 40.0.0.0 255.0.0.0 20.0.0.5
R1(config)#

R1#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

C 10.0.0.0/8 is directly connected, FastEthernet0/0
C 20.0.0.0/8 is directly connected, Serial0/0
S 30.0.0.0/8 [1/0] via 20.0.0.5
S 40.0.0.0/8 [1/0] via 20.0.0.5

r2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

C 20.0.0.0/8 is directly connected, Serial0/0
C 30.0.0.0/8 is directly connected, Serial0/1

r2#config t
Enter configuration commands, one per line. End with CNTL/Z.
r2(config)#ip route 10.0.0.0 255.0.0.0 20.0.0.1
r2(config)#ip route 40.0.0.0 255.0.0.0 30.0.0.5
r2(config)#exit
r2#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

S 10.0.0.0/8 [1/0] via 20.0.0.1
C 20.0.0.0/8 is directly connected, Serial0/0
C 30.0.0.0/8 is directly connected, Serial0/1
S 40.0.0.0/8 [1/0] via 30.0.0.5
r2#

R3#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

C 30.0.0.0/8 is directly connected, Serial0/0
C 40.0.0.0/8 is directly connected, FastEthernet0/0
R3#

R3#config t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#ip route 10.0.0.0 255.0.0.0 30.0.0.1
R3(config)#ip route 20.0.0.0 255.0.0.0 30.0.0.1
R3(config)#exit
R3#
%SYS-5-CONFIG_I: Configured from console by console
R3#show ip route
Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP
i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area
* – candidate default, U – per-user static route, o – ODR
P – periodic downloaded static route

Gateway of last resort is not set

S 10.0.0.0/8 [1/0] via 30.0.0.1
S 20.0.0.0/8 [1/0] via 30.0.0.1
C 30.0.0.0/8 is directly connected, Serial0/0
C 40.0.0.0/8 is directly connected, FastEthernet0/0
R3#

 

statics 1

Fig : Packet passing Source to destination

 

Thank you

Momataj Momo

Skill test : Practical 1 – Basic Router Configuration

 

basic router configR1>en
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#hostname R1
R1(config)#interface fastethernet 0/0
R1(config-if)#description #student lab LAn#
R1(config-if)#ip address 192.168.20.1 255.255.255.0
R1(config-if)#no shutdown

R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#exit
R1(config)#banner motd #next schedule meeting is postponed#
R1(config)#banner motd #unauthorized access is prohbited! enter your user name and password #
R1(config)#ip host momo 172.16.1.1
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#exec-timeout 0 0
R1(config-line)#logging schronous
R1(config-line)#loggin synchronous
R1(config-line)#password console
R1(config-line)#login
R1(config-line)#exit
R1(config)#

R1(config)#line vty 0 4
R1(config-line)#password telnet
R1(config-line)#login
R1(config-line)#exit
R1(config)#
R1(config)#enable secret cisco
R1(config)#exit
R1(config)#enable secret cisco
R1(config)#exit
R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration…
[OK]
R1#

R1#en
R1#config t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#ip domain-name cisco.com
R1(config)#crypto key generate rsa
The name for the keys will be: R1.cisco.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

R1(config)#line vty 0 4
R1(config-line)#transport input ssh
R1(config-line)#login local
R1(config-line)#exit
R1(config)#
R1(config)#username admin privilege 15 password cisco
R1(config)#

PC>telnet 192.168.20.1
Trying 192.168.20.1 …Openunauthorized access is prohbited! enter your user name and password
or
PC>ssh -l admin 192.168.20.1
Open
Passwor:
unauthorized access is prohbited! enter your user name and password

R1#

Skill Test in Packet tracer : Step by Step Basic Global Configuration commands for new learner (CISCO MODULE 1)

cablling

Different Type Device Connection Router to Router ( Fastethernet Interface or Interface Serial Port, Copper Cross over connection) PC to Router ( Copper Crossed Over Connection , Fastethernet interfae ) PC to Switch or Switch to Router ( Copper Straight – through , Interface Fastethernet)

Continue with configuration dialog? [yes/no]: no

Press RETURN to get started!

Router > 

In User Mode: Router > ‘ User mode is indicated with “>” next to the router name . In this mode you can look at setting but can not make changes

In Privilege Mode: Router # To get into Privilege mode the keyword is enable.

To get back user mode from privilege: Router # exit or Disable 

Router > 

From user mode type logout or exit to leave the router 

router > logout or exit

Press Enter to get back Router Prompt 

Router > ? You are now user mode. Type ? to view all the available command at this prompt .

From privilege mode you can enter in configuration mode by typing configure terminal . You can exit configuration mode type Exit or <ctl>+Z

Router > enable

Router #

Router # config t or terminal

router<config> # exit

Router #

To view all commands available from this mode type ?  and press enter. This will give you list of all available command for the router in your current mode.

For example : If you want to use a show command but you do not remember which one it uses “Show ?”

Router # show ? will output all command that you can use with the show command.

Configuration Router or switch  host name : This command works on both routers and switches

Router (config)# hostname R1

R1(config)#

Configuration Password: This command also work on both router and switch

router (conffig) # enable password cisco(Sets enable password to cisco)

Router (config)# enable secret cisco (sets enable secret pw to cisco)

note: The enable secret password is encrypted by default . The enable password is not encrypted . For this reason, Recommended practice is that you never use the enable password command. Use only the enable secret password command in a router or switch configuration .

you can not use / set both enable password or enable secret password to the same time. So by default use encryption password.

Console configuration:  

Router (Config) # line console 0 (enter console line mode)

router (config-line)# password console (sets console line mode pw to console)

router (config-line)# login (enable pw checking at login)

routern(config-line) # exit

Telnet Configuration : 

router (config) # line vty 0 4 (enter vty line mode for all five vty lines)

router(config-line)# password telnet (set vty pw to telnet)

router(config-line)# login (enable pw checking at login)

router(config-line)# exit

Auxiliary configuration : 

router(config)# line aux 0 (enter auxiliary line mode)

router(config-line)# password aux (sets auxiliary line mode pw to aux)

router(config-line)#login (enable pw aux line checking at login)

router(config-line)# exit

Configuration Fast Ethernet Interface :  

router(config)# interface fastethernet 0/0 (move to fastethernet 0/0 interface config mode)

router(config-if)# description #student lab LAN# (optional description of the link is locally significant)

router(config-if)# ip address 10.0.0.0 255.0.0.0 (assign ip address and subnet mask to interface)

router(config-if)#  no shutdown ( turn interface on)

router(config-if)#  exit

Configuration Serial port Interface : 

router(config)# interface serial 0/0 (move to serial 0/0 interface config mode)

router(config-if)# ip address 20.0.0.0 255.0.0.0 (assign ip address and subnet mask to interface)

router (config-if) #clock rate 64000 (if DCE serial port, need to assign clock rate and band width)

router (config-if)#band width 6400

router(config-if)#  no shutdown ( turn interface on)

router(config-if)#  exit

Creating a message of the Day Banner : 

router (config)# banner motd #next schedule meeting with manage is postpone # 

router (config)# 

The MOTD banner is display on all terminals and is useful for sending message that affect all users. use the no banner motd command to disable the motd banner.

router (config)# no banner motd

The MOTD banner displays before the login prompt and the login banner, if one has been created.

Creating a Login Banner : 

router (config)# banner login #unauthorized access is prohibited ! please enter your username and password#

router (config)#

The login banner displays before the username and password login prompts. Use the no banner login command to disable the login banner . The MOTD banner display before the login banner.

#….. # is known as a delimiting character . The delimiting character must surround the banner and login message and can be any character so long as it is not a character used within the body of the message.

Assigning a local host name to an IP address :

router (config)# IP host R2 172.16.1.1 <IP host Hostname IP address )

Assign a host name to the IP address . After this assignment , you can use the host name rather than an IP address when trying to Telnet or Ping to address.

The No IP Domain-looup command: 

router (config)# no ip domain-lookup

router (config)#

Turn off to automatically resolve an unrecognized command to a local lost name. The router is set  by default try to resolve any word that is not a command to a doman name system(DNS) server  address  255..255.255.255

If you are not going to setup DNS, turn off this feature to save your time as you type. 

The Logging synchronous command :  

router (config)# line console

router (config)# exce-timeout 0 0

router (config)#

sets the time limit when the console automatically logs off. sets to 0 0 (minutes seconds) means the console never logs off

The command exce-timeout 0 0 is great for a lab environment because the console never logs out. This is considered to be bad security and is dangerous in the real world. The default for the exce-timeout is 10 minutes and zero (0) seconds .

Saving and erasing configurations:  

router (config)# exit ( during you back in privilage exec-mode)

router (config)# copy running-config startup-config (Saves the running configuration to local NVRAM)

router (config)# copy running-config iftp (saves the running config remotely to a TFTP server)

router (config)# erase startu-config (Delete the startup configuration file from NVRAM)

Thank you

Momtaj Momo

Routing : Brief Description about Routing

Routing : 

Routing is the process by which a packet gets from one direction to another. To route a packet , a router need to know the destination and on what interface to send the traffic out. when a packet comes into an interface on a route , it looks up the destination IP address in the packet header and compares it with its routing table. The routing table , which is stored in RAM, tells the router which outgoing interface the packet should go to reach destination network.

 

There are three ways to control routing decision on router :

  • Static routes
  • Default routes 
  • Dynamic routes

Static Route:  Use a static route when you want to manually define the path that packet will take through your network. Static routes are useful in small network with rarely changing routes, when you have  little bandwidth and do not want the overhead of a dynamic routing protocol or when you want to manually define all of your routes for security reasons .

Static routes are created in Global Configuration mode.

The syntax for the static route in follows :

Route # IP route Destination network address [subnet mask] next-hop-address| interface 

Default routes: This is the special type of static route , commonly called the gateway of last resort. If the specially destination is not listed in the routing table, the default route  can be used to route the packet. A default route has an IP Address of 0.0.0.0 and a subnet mask of 0.0.0.0 , often represented as 0.0.0.0/0 . Default routes are commonly used in small network on a perimeter router pointing to the directly connected ISP router.

Dynamic Routes: Dynamic routes are routes that a router learns by using a routing protocol. Routing protocols will learn about routes from other neighbouring routers running the same routing protocol. Dynamic routing protocols share network numbers a router knows about and how to reach these networks. Through this sharing process, a router can learn about all of the reachable network numbers in the network.

Routing protocol and routed protocol: A routing protocol learn about routes for a routed protocol. 

Routed Protocol : Any Network protocol that provides enough information in its network layer address to enable a packet to be forwarded from one host to another host based on the addressing scheme , without knowing the entire path from source to destination. Packets generally are conveyed from end system to end system IP is an example of routed protocol.

Routing Protocol: Facilities the exchange of routing information between networks , enabling routers to build routing tables dynamically. Traditional IP routing stays simple because it uses next hop (next router) routing in which the router needs to consider only where it sends the packet and does not need to consider the subsequent path of the packets on the remaining hops  (routers) .

*** RIP (Routing information protocol) is an example of a routing protocol.

There are two types of routing protocol: 

  • Interior gateways protocols (IGP) :  These routing protocols exchange routing information within autonomous system. Routing infomation protocol version 2 (RIP V2) , enhanced Interior gateway routing (EIGRP) and open shortest path first (OSPE) are examples of IGPs.
  • Exterior Gateways Protocol (EGP) : These routing protocols are used to route between autonomous system. Border Gateways protocol (BGP) is the EGP of choice in network today. 

Autonomous System : is a group of network under a single administrative control, which could be your company , a division within your company or a group of companies. 

 

Thank you

Momataj Momo