General or Standard Static routing Protocol Configuration

General Static routing

Fig : Static Routing Protocol Setup

Switch 0 Command Line CL1:

Switch>en

Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#ex
Switch(config)#vlan 20
Switch(config-vlan)#ex
Switch(config)#vlan 30
Switch(config-vlan)#ex
Switch(config)#
Switch(config)#vlan 99
Switch(config-vlan)#ex

Switch(config)#int fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
Switch(config-if)#exit
Switch(config)#int fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#ex
Switch(config)#int fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#
Switch(config-if)#exit
Switch(config)#int vlan 30
Switch(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up

Switch(config-if)#ip address 172.16.12.5 255.255.255.0
Switch(config-if)#no shutdown
Switch(config-if)#exit
Switch(config)#line vty 0 5
Switch(config-line)#password cisco
Switch(config-line)#enable secret cisco
Switch(config-line)#exit
Switch(config)#

Switch(config)#ip default-gate 172.16.12.1
Switch(config)#exit

Switch(config)#int fa0/4
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 99
Switch(config-if)#exit
Switch(config)#

Router 0 command line CL1:

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int fa0/0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#
Router(config)#int fa0/0.10
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up

Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip address 172.16.10.1 255.255.255.0
Router(config-subif)#int fa0/0.20
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.20, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.20, changed state to up

Router(config-subif)#encapsulation dot1q 20
Router(config-subif)#ip address 172.16.11.1 255.255.255.0
Router(config-subif)#exit
Router(config)#int fa0/0.30
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up

Router(config-subif)#encapsulation dot1q 30
Router(config-subif)#ip address 172.16.12.1 255.255.255.0
Router(config-subif)#exit
Router(config)#

Router>en

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/0/0
Router(config-if)#ip address 192.168.10.1 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#
Router(config)#ip route 172.22.30.0 255.255.255.0 192.168.10.2
Router(config)#

Router 1 command line CL1:
Router(config-if)#ex
Router(config)#int g0/0
Router(config-if)#ip address 172.22.30.1 255.255.255.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s0/1/0
Router(config-if)#ip address 192.168.10.2 255.255.255.252
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up
Router(config)#ip route 172.16.10.0 255.255.255.0 192.168.10.1
Router(config)#ip route 172.16.11.0 255.255.255.0 192.168.10.1
Router(config)#ip route 172.16.12.0 255.255.255.0 192.168.10.1
Router(config)#

Note: IP Route command :

Router (config): IP ROUTE || DESTINATION NETWORK|  ADDRESS DESTINATION MASK||  NEXT HOP ADDRESS OR EXITS INTERFACE OR BOTH||

Thank you

Momataj Momo

Advertisements