Practical: Skill test on INTER-VLAN, RIP2, DYNAMIC NAT, ACL

Configure the network according to following table:

Network Description Net Address Mask Gateway Clock Rate
Vlan 10(Teacher) 172.16.10.0 255.255.255.0 172.16.10.1 NA
Vlan 20 (Student) 172.16.11.0 255.255.255.0 172.16.11.1 NA
Management Vlan 30(Managemrnt) 172.16.12.0

172.16.13.0

255.255.255.248 172.16.12.1

172.16.13.1

NA
R1 (Internal) to R2(AIUB) Serial 192.168.10.0 255.255.255.252 192.168.10.1 and 192.168.10.2 64000
R2 (AIUB) to R3(ISP) 192.168.11.0 255.255.255.252 192.168.11.1 and 192.168.11.2 64000
PC1(Vlan 10) connected to Switch 1 172.16.10.2 255.255.255.0 172.16.10.1 NA
Server(Vlan 20) connected to Switch 2 172.16.11.2 255.255.255.0 172.16.11.1 NA

 Required to configure the following : 

All Switch must be remotely accessible 

Perform inter vlan routing

Apply RIP version 2 in Internal and AIUB routers

RIP update must not go to any LAN

Configure default route from AIUB to ISP and propagate it to all router in RIP

Propagate default route to all router in RIP

Configure static route from ISP to AIUB and Internal networks

Apply numbered extended ACL to stop ping from PC1 to Server and Stop telnet to server form PC1

AIUB to ISP perform dynamic PAT for all internal networks towards ISP. Use public IP 200.20.2.1/30

solution

Topology Configuration

All Switch must be remotely accessible:
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SW1
SW1(config)#line console 0
SW1(config-line)#logging synchronous
SW1(config-line)#password cisco
SW1(config-line)#login
SW1(config-line)#exit

SW1(config)#line vty 0 5
SW1(config-line)#logging synchronous
SW1(config-line)#password cisco
SW1(config-line)#login
SW1(config-line)#exit
SW1(config)#

SW1(config)#enable secret cisco
SW1(config)#service password-encryption
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname SW2
SW2(config)#line console 0
SW2(config-line)#logging sy
SW2(config-line)#logging synchronous
SW2(config-line)#password cisco
SW2(config-line)#login
SW2(config-line)#exit
SW2(config)#
SW2(config)#
SW2(config)#line vty 0 5
SW2(config-line)#logging syn
SW2(config-line)#logging synchronous
SW2(config-line)#password cisco
SW2(config-line)#login
SW2(config-line)#exit
SW2(config)#

SW2(config)#enable secret cisco
SW2(config)#service password-encryption
SW2(config)#
Perform inter vlan routing:
SW1(config)#vlan 10
SW1(config-vlan)#name Teacher
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW1(config-vlan)#name Student
SW1(config-vlan)#exit
SW1(config)#vlan 30
SW1(config-vlan)#name Management
SW1(config-vlan)#exit
SW1(config)#
SW1(config)#vlan 99
SW1(config-vlan)#name native
SW1(config-vlan)#
SW1(config)#int vlan 30
SW1(config-if)#ip address 172.16.12.3 255.255.255.248
SW1(config-if)#ip default-gateway 172.16.12.1
SW1(config)#exit
SW1(config)#int fa0/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10
SW1(config-if)#exit
SW1(config)#
SW1(config)#int fa0/1
SW1(config-if)#no shutdown

SW1(config)#int fa0/2
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk allowed vlan 10,20,30,99
SW1(config-if)#switchport trunk native vlan 99
SW1(config-if)#

SW1(config)#int fa0/2
SW1(config-if)#no shutdown
SW1(config-if)#exit
SW1(config)#

SW2#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#vlan 10
SW2(config-vlan)#name Teacher
SW2(config-vlan)#exit
SW2(config)#vlan 20
SW2(config-vlan)#name Student
SW2(config-vlan)#exit
SW2(config)#vlan 30
SW2(config-vlan)#name Management
SW2(config-vlan)#exit
SW2(config)#vlan 99
SW2(config-vlan)#name native
SW2(config-vlan)#exit
SW2(config)#
SW2(config)#int vlan 30
SW2(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

SW2(config-if)#ip address 172.16.13.2 255.255.255.248
SW2(config-if)#ip default-gateway 172.16.13.1
SW2(config)#exit
SW2#
%SYS-5-CONFIG_I: Configured from console by console

SW2#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#int fa0/1
SW2(config-if)#switchport mode access
SW2(config-if)#switchport access vlan 20
SW2(config-if)#exit
SW2(config)#
SW2(config)#int fa0/1
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#

SW2(config)#int fa0/2
SW2(config-if)#switchport mode trunk
SW2(config-if)#switchport trunk allowed vlan 10,20,30,99
SW2(config-if)#switchport trunk native vlan 99
SW2(config-if)#exit
SW2(config)#

SW2(config)#int fa0/2
SW2(config-if)#no shutdown
SW2(config-if)#exit
SW2(config)#

INTERNAL ROUTER CONFIG:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname INTERNAL
INTERNAL(config)#

INTERNAL(config)#int g0/0
INTERNAL(config-if)#no shutdown
INTERNAL(config)#int g0/0.10
INTERNAL(config-subif)#encapsulation dot1q 10
INTERNAL(config-subif)#ip address 172.16.10.1 255.255.255.0
INTERNAL(config-subif)#exit

INTERNAL(config)#int g0/0.30
INTERNAL(config-subif)#encapsulation dot1q 30
INTERNAL(config-subif)#ip address 172.16.12.1 255.255.255.248
INTERNAL(config-subif)#exit
INTERNAL(config)#

INTERNAL(config)#int g0/1.20
INTERNAL(config-subif)#en
INTERNAL(config-subif)#encapsulation
INTERNAL(config-subif)#encapsulation dot1Q 20
INTERNAL(config-subif)#ip address 172.16.11.1 255.255.255.0
INTERNAL(config-subif)#exit
INTERNAL(config)#

NTERNAL(config)#int g0/1.30
INTERNAL(config-subif)#en
INTERNAL(config-subif)#encapsulation
INTERNAL(config-subif)#encapsulation dot1Q 30
INTERNAL(config-subif)#ip address 172.16.13.1 255.255.255.248
INTERNAL(config-subif)#exit
INTERNAL(config)#
INTERNAL(config)#int g0/1
INTERNAL(config-if)#no shutdown
Apply RIP version 2 in Internal and AIUB routers:

INTERNAL(config)#
INTERNAL(config)#int s0/1/0
INTERNAL(config-if)#ip address 192.168.10.1 255.255.255.252
INTERNAL(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
INTERNAL(config-if)#clock rate 64000
INTERNAL(config-if)#exit
INTERNAL(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname AIUB
AIUB(config)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname AIUB
AIUB(config)#int s0/1/0
AIUB(config-if)#ip address 192.168.10.2 255.255.255.252
AIUB(config-if)#no shutdown

AIUB(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up
exit
AIUB(config)#

AIUB(config)#int s0/1/1
AIUB(config-if)#ip address 192.168.11.1 255.255.255.252
AIUB(config-if)#clock rate 64000
AIUB(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
AIUB(config-if)#
AIUB(config-if)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ISP
ISP(config)#int s0/3/0
ISP(config-if)#ip address 192.168.11.2 255.255.255.252
ISP(config-if)#no shutdown

ISP(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

ISP(config-if)#
INTERNAL(config)#router rip
INTERNAL(config-router)#version 2
INTERNAL(config-router)#network 172.16.0.0
INTERNAL(config-router)#network 192.168.0.0
INTERNAL(config-router)#exit
INTERNAL(config)#

AIUB(config)#router rip
AIUB(config-router)#version 2
AIUB(config-router)#network 192.168.10.0
AIUB(config-router)#network 192.168.11.0
AIUB(config-router)#exit
AIUB(config)#

Propagate default route to all router in RIP :

AIUB(config)#router rip
AIUB(config-router)#version 2
AIUB(config-router)#default-information originate
AIUB(config-router)#

AIUB(config)router rip
AIUB(config-router)#version 2
AIUB(config-router) redistribute static
AIUB to ISP perform dynamic PAT for all internal networks towards ISP. Use public IP 200.20.2.1/30

AIUB(config)#ip nat pool INTERNET 200.20.2.1 200.20.2.3 netmask 255.255.255.252
AIUB(config)#
AIUB(config)#ip nat inside source list 1 pool INTERNET
AIUB(config)#ip nat inside source static 192.168.10.2 200.20.2.4
AIUB(config)#ip access-list standard 1
AIUB(config-std-nacl)#permit 172.16.10.0 0.0.0.255
AIUB(config-std-nacl)#permit 172.16.11.0 0.0.0.255
AIUB(config-std-nacl)#int s0/1/0
AIUB(config-if)#ip nat inside
AIUB(config-if)#exit
AIUB(config)#

AIUB(config)#int s0/1/1
AIUB(config-if)#ip nat outside
AIUB(config-if)#

AIUB#show ip nat translations

Configure default route from AIUB to ISP and propagate it to all router in RIP

Internal(config)#ip route 0.0.0.0 0.0.0.0 s0/1/0
AIUB(config)#ip route 0.0.0.0 0.0.0.0 Serial0/1/1

RIP update must not go to any LAN:
Internal(config)#router rip
Internal(config)# version 2
Internal(config)# passive-interface GigabitEthernet0/0
Internal(config)# passive-interface GigabitEthernet0/1

Apply numbered extended ACL to stop ping from PC1 to Server and Stop telnet to server form PC1
Internal(config)#ip access-list extended 110
Internal(config-ext-nacl)#
Internal(config-ext-nacl)#permit tcp any any eq telnet
Internal(config-ext-nacl)#deny tcp 172.16.10.2 0.0.0.255 eq telnet 172.16.13.2 0.0.0.7 eq telnet
Internal(config-ext-nacl)#deny icmp 172.16.10.2 0.0.0.255 172.16.11.2 0.0.0.255 echo
Internal(config-ext-nacl)#deny icmp 172.16.10.2 0.0.0.255 172.16.11.2 0.0.0.255 echo-reply

Thank you

Momataj Momo

Advertisements

IPv4 : Subnet Mask and Subnetting

A subnetwork, or subnet, is a logically visible subdivision of an IP Network. The practice of dividing a network into two or more networks is called subnetting.

All computers that belong to a subnet are addressed with a common, identical, most-significant bit-group in their IP Address. This results in the logical division of an IP address into two fields, a network or routing prefix and the rest field or host identifier. The rest field is an identifier for a specific host or network interface.

A Subnet Mask is a bitmask that encodes the prefix length in quad-dotted notation: 32 bits, starting with a number of 1 bits equal to the prefix length, ending with 0 bits, and encoded in four-part dotted-decimal format. A subnet mask encodes the same information as a prefix length, but predates the advent of CIDR. However, in CIDR notation, the prefix bits are always contiguous, whereas subnet masks may specify non-contiguous bits. However, this has no practical advantage for increasing efficiency

For IPv4, a network is also characterized by its subnet mask, which is the bitmap that when applied by a logical AND operation to any IP address in the network, yields the routing prefix. Subnet masks are also expressed in dot-decimal notation like an address.

For example, 255.255.255.0 is the network mask for the 192.168.1.0/24 prefix.

Classless Inter-Domain Routing (CIDR) is a method for allocating IP addresses and routing Internet Protocol packets.CIDR notation is a syntax for specifying IP addresses and their associated routing prefix. It appends a slash character to the address and the decimal number of leading bits of the routing prefix, example: 192.168.2.0/24 for IPv4, and 2001:db8::/32 for IPv6.

CIDR addresses reduce the size of routing tables and make more IP addresses available within organizations. CIDR is also called Supnetting.

A custom subnet mask borrows bit from the host portions of IP address to create a subnet mask address between the network and host of an IP address.

Number of subnet = 2s

Second Subnet formula = 2s  – 2

Number of hosts per subnet = 2h -2

The first range of address is the zero subnet or the number for the classful subnet address. another the last range of address is the broadcast subnet.

Number of host = the first in very rang is the subnet number.

The last number in every range is the broadcast address. Those two number can not assigned of any device in the network which is why you have to subnet two addresses to find the number of usable address in each range.

A broadcast address is a logical address at which all devices connected to a multiple-access communications network are enabled to receive datagrams. A message sent to a broadcast address is typically received by all network-attached hosts, rather than by a specific host.

n Internet Protocol Version 4 (IPv4) networks, broadcast addresses are formed by a distinguished value for the host identification field, traditionally called the rest field, of an IP address. 

The broadcast address for an IPv4 host can be obtained by performing a bitwise OR operation between the bit complement of the subnet mask and the host’s IP address. In other words, take the host’s IP address, and set to ‘1’ any bit positions which hold a ‘0’ in the subnet mask.

Example: For broadcasting a packet to an entire IPv4 subnet using the private IP address space 172.16.0.0/12, which has the subnet mask 255.240.0.0, the broadcast address is 172.16.0.0 | 0.15.255.255 = 172.31.255.255.

A special definition exists for the IP broadcast address 255.255.255.255. It is the broadcast address of the zero network or 0.0.0.0, which in Internet Protocol standards stands for this network, i.e. the local network. Transmission to this address is limited by definition, in that it is never forwarded by the routers connecting the local network to other networks.

IP broadcasts are used by BOOTP and DHCP clients to find and send requests to their respective servers.

Calculation of Network address: 

Example of classful IP:

Class A IP Address : 10.10.10.0. Network address : 10.0.0.0 

192.168.10.1 – Class C IP address. Network Address : 192.168.10.0 .

For Classless – Inter-domain routing (CIDR) Calculaton: 

1. 172.16.129.0/17

Network bit or CIDR = 17

172.16.10000000.0

Network address : 127.16.128.0 /17 

Subnet mask : 255.255.128.0 

Network bit always start from left side and host bit always consider in zero after network bit.

Number of network address = 217

Number of host address = 215  – 2

2. 172.16.205.0/21

172.16.11111000.0/21

Network Address : 172.16.248.0/21

Subnet Mask : 255.255.248.0 

 

 

Subnet Mask:

 172.16.205.0/21 -Host IP

172.16.11001000.0/21

Network address : 172.16.11111000.0/21

Host IP AND Operation of Network Address = Subnet Mask

The Subnet Mask is a network generate number that identities the network to which an IP address belongs. It’s the number does not began with 255. It’s not subnet mask.

Class A: 255.0.0.0
Class B: 255.255.0.0
Class C: 255.255.255.0

An IP address on a Class A network that has not been subnetted would have an address/mask pair similar to: 8.20.15.1 255.0.0.0. To see how the mask helps you identify the network and node parts of the address, convert the address and mask to binary numbers.

8.20.15.1 = 00001000.00010100.00001111.00000001
255.0.0.0 = 11111111.00000000.00000000.00000000
Any address bits which have corresponding mask bits set to 1 represent the network ID. Any address bits that have corresponding mask bits set to 0 represent the node ID.

8.20.15.1 = 00001000.00010100.00001111.00000001
255.0.0.0 = 11111111.00000000.00000000.00000000
————————————————————————–
                  net id      |           host id

netid = 00001000 = 8
hostid = 00010100.00001111.00000001 = 20.15.1

 

IP Subnetting:

To subnet a network is to create logical divisions of the network.Subnetting, therefore, involves dividing the network into smaller portions called subnets. Subnetting applies to IP addresses because this is done by borrowing bits from the host portion of the IP address. In a sense, the IP address then has three components – the network part, the subnet part and, finally, the host part.

We create a subnet by logically grabbing the last bit from the network component of the address and using it to determine the number of subnets required.

c930b3abeddb4d9cb730f0d1efd339cc

Example: a Class C address normally has 24 bits for the network address and eight for the host, but we are going to borrow the left-most bit of the host address and declare it as identifying the subnet.

If the bit is a 0, then that will be one subnet; if the bit is a 1, that would be the second subnet. Of course, with only one borrowed bit we can only have two possible subnets. By the same token, that also reduces the number of hosts we can have on the network to 27 (or 125) hosts, down from 255.

The reason a subnet mask has this name is that it literally masks out the host bits being borrowed from the host address portion of the IP address.In the following diagram, there is a subnet mask for a Class C address. The subnet mask is 255.255.255.128 which, when translated into bits, indicates which bits of the host part of the address will be used to determine the subnet number.

226b533445ac45e4b5021d01bacc0927

Subnetting mainly divided Network into small network. Subnetting from subnet. Its increase network bit from borrow its host bts.

Example 1 : IP address, 172.16.10.1 , Network address 172.16.0.0.. Divided this IP among 10 subnet into different networks address within 10 floor .

Answer: Rule 1: 10<= 16 = 24       bits  ( 10 because its given 10 floor network address  and 2means how many host its need to borrow from host ID)

Rule 2: 172.16.0000 | 0000.0 ( 20 network bit and 12 host bit because class B has 16 bit network address plus 4 bits borrow from host bits)

Rule 3: Binary                                      decimal

             0000                                                0                  Floor -1

             0001                                                1                  Floor – 2

             0010                                                 2                 Floor -3

             .

             .

             .

             1111                                                 15                Floor 16

SO ,

Floor -1 = 172.16.0.0/20

Floor – 2= 172.16.0001 | 0000.0 /20

                 = 172.16.16.0/20

Floor -3 = 172.16.0010 | 0000.0/20

              = 172.16.32.0/20

Floor – 10 = 172.16.1001 | 0000 .0 /20 (always remember floor 10 means Decimal 9 (n-1))

                   = 172.16.144.0/20

Floor – 15 = 172.16.1110 | 0000.0/20

                  = 172.16.208.0/20

Example 2 : 172.16.0.0 Divided this IP among 17 subnet .what is Network address of 29th subnet.

Answer:  17 < = 25       means 32 bits (8+5 =21 network bit)

                  29 th floor means (n-1) = 28 number of floor.

                   29th floor network address : 172.16.11100 | 000.0/21

                                                               = 172.16.224.0/21

Example 3: 10.128.0.0 /9 Divided this network among 256 network. what is the 201 th subnet network address and subnet mask.

Answer: 256 = 2(9+8 = 17 network bits) and 201th subnet network address means (201-1)= 200 number of subnet address.

201 th subnet network address = 10.1 | 0000000.0 | 0000000.0/17

                                                        =10.1 | 1100100 .0.0 /17

                                                         = 10.228.0.0/17

              Host bit = 32-17 = 15 bit, Number of host bit 215, 

              Usable host bit : 215-2       every subnet has useless two host bit .

             Default subnet Mask: 255.255.0.0.

             Range of host address : 10.228.0.1 / 17 to 10.228.127.255/17. 

             Network address: 10.228.128.0 

             subnet mask: 255.255.128.0

              Number of network address = 217

              Number of Usable network address =217-2

Example 4: 192.168.10.0 / 24 . Divided this IP among 5 subnets. How many usable host in each subnet.

         a) what is the network address of the 4th subnet?

         b) What is the subnet mask of each subnet?

Answer:                           5 subnets <= 23    means = 8 bits (3 bit required from host bits, network bit = 24+3 = 27bits)

Class C : 192. 168.10. 000 | 00000 /27

Usable host bit = 25-2 = 32-2 = 30

Borrow bit = 23 = 8 bits

Default mask = 255.255.255.0

Custom Mask : 255.255.255.224

4th subnet = 4-1 = 3 number of subnet address

                   = 192.168.10.011 | 00000 /27

                   = 192.168.10.96/27

Range : 192.168.10.0 to 192.168.10.31 (because host bits 32)

               192.168.10.32 to 192.168.10.63

               192.168.10.64 to 192.168.10.95

                192.168.10.96 to 192.168.10.127

                192.168.10.128 to 192.168.10.223

                192.168.10.224 to 192.168.10.255

Related Terms: 

IP Address: A logical numeric address that is assigned to every single computer, printer, switch, router or any other device that is part of a TCP/IP-based network
Subnet: A separate and identifiable portion of an organization’s network, typically arranged on one floor, building or geographical location
Subnet Mask: A 32-bit number used to differentiate the network component of an IP address by dividing the IP address into a network address and host address
Network Interface Card (NIC): A computer hardware component that allows a computer to connect to a network.

The Wildcard is the inverse netmask as used for access control lists in Cisco routers.

Broadcast : broadcast address is special address which is used by intermediary device .   

 

Thank you

Momataj Momo

 

 

 

 

 

 

Skill Test : Practical – 3 Configuration DHCP server on a Cisco Router

DHCP

Topology : Configuration DHCP server through Packet tracer

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0

Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Router(config-if)#exit
Router(config)#interface fastethernet 0/1
Router(config-if)#ip address 20.0.0.1 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Router(config-if)#exit
Router(config)#

Configuration DHCP Pool for network : 

In Router , Global Configuration mode,

Router(config)#service dhcp
Router(config)#ip dhcp pool 10network (name of pool) This command get us into the DHCP configuration

Router(dhcp-config)#network 10.0.0.0 255.0.0.0 It defines the network range to be released 

Router(dhcp-config)#dns-server 10.0.0.5  IP address for the DNS server
Router(dhcp-config)#default-router 10.0.0.1 Default gateway for the network
Router(dhcp-config)#exit
Router(config)#

Router(config)#ip dhcp pool 20network
Router(dhcp-config)#network 20.0.0.0 255.0.0.0
Router(dhcp-config)#dns-server 10.0.0.5
Router(dhcp-config)#default-router 20.0.0.1
Router(dhcp-config)#exit
Router(config)#

Now click on any of the PC -> Desktop-> IP Configuration – > choose DHCP . Now PC will get an IP from DHCP Server.

In addition command:

you can use :

Router(dhcp-config)# domain-name Firewall.cx
Router(dhcp-config)# lease 9

The domain-name and lease parameters are not mandatory. By default, the lease time for an IP address is one day, however we can specify any time range we need. For example, if we need to set the lease time for 4 hours and 30 minutes we would use the following command under our DHCP pool:

Router(dhcp-config)# lease 0 4 30

The above command is interpreted as follows: 0 (Zero) days, 4 hours and 30 minutes.

If you want  to exclude the IP addresses you don’t want DHCP server giving out. Drop back to ‘global configuration mode’ and enter the following:

Router(config)# ip dhcp excluded-address 10.0.0.5 10.0.0.7
Router(config)# ip dhcp excluded-address 10.0.0.10

This excludes IP addresses 10.0.0.5 to  10.0.0.7 & 10.0.0.10. As you can see, there’s an option to exclude a range of IP addresses or a specific address.

Troubleshoot: 

The above configuration is all you need to get the DHCP server running for your network. We’ll provide a few more commands you can use to troubleshoot and ensure it’s working correctly.

Router# show ip dhcp binding

Router#show ip dhcp binding (Displays a list of all binding created)

IP address Client-ID/ Lease expiration Type

Hardware address

10.0.0.2 0001.63B0.74CB — Automatic

10.0.0.3 0060.3E14.15B1 — Automatic

10.0.0.4 0090.218C.0612 — Automatic

20.0.0.2 00D0.9711.81CA — Automatic

20.0.0.3 0050.0F03.11E9 — Automatic

20.0.0.4 000C.CF7E.B9BE — Automatic

Router#

Router# show ip dhcp binding 10.0.0.4 (displays the binding for a specific DHCP client with an IP address of 10.0.0.4)

Router# clear IP dhcp binding 10.0.0.4 (clear an automatic binding from the DHCP server database)

Router# Show ip dhcp confict (display a list of all address conflicts recorded by DHCP)

Router#clear ip dhcp conflict 10.0.0.3 (clear address conflict from database)

Router# clear ip dhcp conflict* (clear conflicts for all address)

Router# show ip dhcp database (display recent activity on the dhcp server)

Router# show ip dhcp server statistics ( Display a list of the number )

Router# clear ip dhcp server statistics  

Thank you

Momtaj Momo

Skill test in Packet tracer : Configure the switch to be accessed by TELNET

Topology :

tropology

Click on Switch O and go to CL1 (command line)

Switch>en  (enable Switch It’s user mode or Privileged mode)
Switch#config t (configuration terminal –  From privileged mode you can enter in configuration mode by tying configure terminal. you can exit configuration mode type exit or <CTL>+Z
Enter configuration commands, one per line. End with CNTL/Z.

Console Configuration: 

Switch>en

Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#line console 0
Switch(config-line)#pass cisco
Switch(config-line)#login
Switch(config-line)#exit
Switch(config)#
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Telnet configuration : 

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#line vty 0 4 ( 0 4 means just 4 user can access at the same time , the fifth user not allowed)

Switch(config-line)#pass cisco

Switch(config-line)#login

Switch(config-line)#exit

Switch(config)#exit

Switch#

%SYS-5-CONFIG_I: Configured from console by console

Switch#exit

Configure Console Password and Vlan 1:

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

Switch(config)#enable password cisco

Switch(config)#interface vlan 1

Switch(config-if)#ip address 172.17.1.1 255.255.0.0

Switch(config-if)#no shutdown

Switch(config-if)#

%LINK-5-CHANGED: Interface Vlan1, changed state to up

Switch#wr

Building configuration…

[OK]

Switch#

Switch#

CL1

CL1 prompt for switch configuration

 

Now click on PC. Desktop -> IP configuration 172.17.1.2 subnet mask 255.255.0.0 ( IP should be in the same range of VLAN 1)

 

 

Static IP assign

Static IP Address Assign for PC

click on Command Prompt :

PC> Telnet 172.17.1.1

password: cisco

switch >

switch > enable

Password: cisco

switch # config t 

telnet login

From Command Prompt : PC> Telnet login

Thank you

Momataj momo

Introduction to Networking

What is Network?

– When two or more nodes (element of network ) are interconnected.

Base on Geographical location :

a) LAN ( Local Area Network)

b) MAN ( Metropolitan Area Network)

c)  WAN ( wide Area Network)

Others Networks are : HAN ( Home Area Network), PAN ( Personal Area Network), CAN ( Controller Area Network), BAN (Body Area Network)

BAN: A Body Area Network is formally defined by IEEE 802.15 as, “a communication standard optimized for low power devices and operation on, in or around the human body (but not limited to humans) to serve a variety of applications including medical, consumer electronics / personal entertainment and other“.

In a short, a Body Area Network is a system of devices in close proximity to a persons body that cooperate for the benefit of the user.

Connecting Device for Networking :

1. Inter-connection Device ( such as Network Interface card, Repeater, Hub, Bridge , Switch , Router)

2. Transmission Medium (A Transmission medium is a material substance that can propagate energy waves. For example, the transmission medium for sounds is usually air, but solids and liquids may also act as transmission media for sound. For Example : Electromagnetic Radiation can be transmitted through an  Optical medium such as Optical Fiber, or through  twisted pair wires, coaxial cable, or dielectric-slab wave-guides.)

3. Communication protocol (  A communication protocol is a system of digital rules for data exchange within or between computers) 

Inter-connection Device , Short Description :

a) Network Interface Card (NIC) is commonly known as LAN Card . Every LAN Card has a globally unique physical Address or MAC (media access control address) address. 

A media access control address (MAC address) is a unique identifier assigned to network interfaces for communications on the physical network segment. MAC addresses are used as a network address for most IEEE 802network technologies, including  Ethernet. Logically, MAC addresses are used in the media access control protocol sub layer of the OSI reference Model.

Every MAC address is 48 bits long. for example : -5a-bc-6d-42-ab-52 

-5a-bc-6d : First 24 bits represent vendor ID or Manufacturer ID

-42-ab-52 : last 24 bits represent product ID

b) Repeater : A repeater mainly forward single source to destination. In Telecommunication, a repeater is an electronic device that receives a signal and re-transmits it at a higher level or higher power, or onto the other side of an obstruction, so that the signal can cover longer distances. 

c) HUB:  An Ethernet hub, active hub, network hub, repeater hub, multiport repeater or hub is a device for connecting multiple Ethernet devices together and making them act as a single network segment . It has multiple input/output (I/O) ports, in which a signal introduced at the input of any port appears at the output of every port except the original incoming.

A hub works at the Physical Layer (Layer -1 ) of the  OSI Model . Repeater hubs also participate in collision detection, forwarding a jam signal to all ports if it detects a collision.

d) Switch : A network switch (sometimes known as a switching hub) is a computer networking device that is used to connect devices together on a computer network by performing a form of packet switching. A switch is considered more advanced than a Hub because a switch will only send a message to the device that needs or requests it, rather than broadcasting the same message out of each of its ports.

A switch is a multi-port network bridge that processes and forwards data at the data link layer (layer 2) of the OSI Model. Some switches have additional features, including the ability to route packets. These switches are commonly known as layer-3 or multilayer switches.

In switch , RAM mainly maintain MAC address table.

e) Router : Routers are small physical devices that join multiple networks together. Technically, a router is a Layer 3 gateway device, meaning that it connects two or more networks and that the router operates at the network layer of the OSI model.

Routers perform the “traffic directing” functions on the Internet. A data packet is typically forwarded from one router to another through the networks that constitute the internetwork until it reaches its destination node.

Switches create a network. Routers connect networks. A router links computers to the Internet, so users can share the connection. A router acts as a dispatcher, choosing the best path for information to travel so it’s received quickly.

Thank you

Momataj Momo