Skill Test : Configuration of Frame Relay

Untitled

Part 1 Configure Frame-Relay:

R1:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int s0/1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shut

R1(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R1(config-if)#

R1(config-if)#exit
R2:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int s0/1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R2(config-if)#exit
R2(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int s0/1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R3(config-if)#exit

Part 2: Configure Frame Relay Point-to-Point Subinterfaces
R1(config)#int s0/1/0.102 point
R1(config)#int s0/1/0.102 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.102, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.102, changed state to up

R1(config-subif)#ip address 10.1.1.1 255.255.255.252
R1(config-subif)#bandwidth 64
R1(config-subif)#frame-relay interface-dlci 102
R1(config-subif)#exit

R1(config)#int s0/1/0.103 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.103, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.103, changed state to up

R1(config-subif)#ip address 10.1.3.2 255.255.255.252
R1(config-subif)#bandwidth 64
R1(config-subif)#frame-relay interface-dlci 103
R1(config-subif)#exit
R1(config)#

R2(config)#int s0/1/0.201 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.201, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.201, changed state to up

R2(config-subif)#ip address 10.1.1.2 255.255.255.252
R2(config-subif)#bandwidth 64
R2(config-subif)#frame-relay interface-dlci 201
R2(config-subif)#exit
R2(config)#

R2(config)#int s0/1/0.203 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.203, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.203, changed state to up

R2(config-subif)#ip address 10.1.2.1 255.255.255.252
R2(config-subif)#bandwidth 64
R2(config-subif)#frame-relay interface-dlci 203
R2(config-subif)#exit
R2(config)#

R3(config)#int s0/1/0.301 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.301, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.301, changed state to up

R3(config-subif)#ip address 10.1.3.1 255.255.255.252
R3(config-subif)#bandwidth 64
R3(config-subif)#frame-relay interface-dlci 301
R3(config-subif)#exit
R3(config)#

R3(config)#int s0/1/0.302 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.302, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.302, changed state to up

R3(config-subif)#ip address 10.1.2.2 255.255.255.252
R3(config-subif)#bandwidth 64
R3(config-subif)#frame-relay interface-dlci 302
R3(config-subif)#exit
R3(config)#
Router Configuration :

R1(config)#int g0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config)#int g0/0
R2(config-if)#ip address 192.168.30.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config-if)#exit
R2(config)#

R3(config)#int s0/1/1
R3(config-if)#ip address 209.165.200.225 255.255.255.224
R3(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
R3(config-if)#
R3(config-if)#clock rate 64000
R3(config-if)#exit
R3(config)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ISP
ISP(config)#int s0/3/0
ISP(config-if)#ip address 209.165.200.226 255.255.255.224
ISP(config-if)#no shut

ISP(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

ISP(config-if)#

ISP(config)#int g0/0
ISP(config-if)#ip address 209.165.200.1 255.255.255.252
ISP(config-if)#no shut

ISP(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

ISP(config-if)#
R1(config-if)#router eigrp 1
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#network 10.1.3.0 0.0.0.3
R1(config-router)#network 192.168.10.0 0.0.0.255
R1(config-router)#exit
R1(config)#
R2(config)#router eigrp 1
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#network 10.1.2.0 0.0.0.3
R2(config-router)#network 192.168.30.0 0.0.0.255
R2(config-router)#exit
R2(config)#

R3(config)#router eigrp 1
R3(config-router)#network 10.1.3.0 0.0.0.3
R3(config-router)#network 10.1.2.0 0.0.0.3
R3(config-router)#network 209.165.200.0 0.0.0.31
R3(config-router)#

Thank you

Momataj Momo

Skill Test : EIGRP Configuration

EIGRP

Configuration Command Line: 

Router(config)#hostname R1
R1(config)#
R1(config)#int g0/0
R1(config-if)#ip address 172.16.1.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#exit
R1(config)#int s0/3/0
R1(config-if)#ip address 172.16.3.1 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/0, changed state to down
R1(config-if)#
R1(config-if)#
R1(config)#int s0/3/1
R1(config-if)#ip address 192.168.10.6 255.255.255.252
R1(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/1, changed state to down
R1(config-if)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#

R2(config)#int g0/0
R2(config-if)#ip address 172.16.2.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config-if)#

R2(config-if)#exit
R2(config)#int s0/3/0
R2(config-if)#ip address 172.16.3.2 255.255.255.252
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

R2(config-if)#

R2(config)#int s0/3/1
R2(config-if)#ip address 192.168.10.9 255.255.255.252
R2(config-if)#clock rate 64000
R2(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/3/1, changed state to down
R2(config-if)#exit
R2(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#

R3(config)#int g0/0
R3(config-if)#ip address 192.168.1.1 255.255.255.0
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R3(config-if)#

R3(config)#int s0/3/1
R3(config-if)#ip address 192.168.10.10 255.255.255.252
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/1, changed state to up

R3(config-if)#exit
R3(config)#

R3(config)#int s0/3/0
R3(config-if)#ip address 192.168.10.5 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

R3(config-if)#

EIGRP Command Line: 

R1(config)#router eigrp 10
R1(config-router)#network 172.16.1.0 0.0.0.255
R1(config-router)#network 192.16.3.0 0.0.0.3
R1(config-router)#network 192.168.10.4 0.0.0.3
R1(config-router)#
R2(config)#router eigrp 10
R2(config-router)#network 172.16.2.0 0.0.0.255
R2(config-router)#network 172.16.3.0 0.0.0.3
R2(config-router)#network 172.168.10.8 0.0.0.3
R2(config-router)#
R3(config)#router eigrp 10
R3(config-router)#network 192.168.10.8 0.0.0.3
R3(config-router)#network 192.168.10.4 0.0.0.3
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 10: Neighbor 192.168.10.6 (Serial0/3/0) is up: new adjacency

R3(config-router)#network 192.168.1.0 0.0.0.255
R3(config-router)#

Thank you

Momataj Momo

Practical : Simple EIGRP Configuration

EIGRP 2

EIGRP Topology

Configuration Command line for EIGRP 

R1(config)#router eigrp 1
R1(config-router)#network 192.168.5.0 0.0.0.127
R1(config-router)#network 192.168.5.224 0.0.0.3
R1(config-router)#network 192.168.5.228 0.0.0.3
R1(config-router)#redistribute static
R1(config-router)#no auto-summary
R1(config-router)#end
R1#show ip eigrp topology
R1#show ip eigrp topology all-links
R1#show ip eigrp neighbors
R0(config)#int s2/0
R0(config-if)#bandwidth 64

network 1: 192.168.5.0 – .127 /25
network 2: 192.168.5.128 – .191 /26
network 3: 192.168.5.192 – .223 /27
network 4: 192.168.5.224 – .227 /30
network 5: 192.168.5.228 – .231 /30
network 6: 192.168.5.232 – .235 /30

wildcard bits subtractor
255.255.255.255
255.255.255.224
———————
0.0.0.31
R1>

interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.128
interface Serial2/0
ip address 192.168.5.229 255.255.255.252
interface Serial3/0
ip address 192.168.5.226 255.255.255.252
clock rate 64000

router eigrp 1
network 192.168.5.0 0.0.0.127
network 192.168.5.224 0.0.0.3
network 192.168.5.228 0.0.0.3
no auto-summary
R2>

interface FastEthernet0/0
ip address 192.168.5.129 255.255.255.192

interface Serial2/0
ip address 192.168.5.225 255.255.255.252

interface Serial3/0
ip address 192.168.5.234 255.255.255.252
clock rate 64000
NO Shutdown

router eigrp 1
network 192.168.5.128 0.0.0.63
network 192.168.5.224 0.0.0.3
network 192.168.5.232 0.0.0.3
NO auto-summary

R3>

interface FastEthernet0/0
ip address 192.168.5.193 255.255.255.224
interface Serial3/0
ip address 192.168.5.230 255.255.255.252
clock rate 64000
router eigrp 1
network 192.168.5.192 0.0.0.31
network 192.168.5.232 0.0.0.3
network 192.168.5.228 0.0.0.3
No auto-summary

Thank you

Momataj Momo