Skill Test : Configuration of Frame Relay

Untitled

Part 1 Configure Frame-Relay:

R1:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int s0/1/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#no shut

R1(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R1(config-if)#

R1(config-if)#exit
R2:
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#int s0/1/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R2(config-if)#exit
R2(config)#

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int s0/1/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#no shut

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0, changed state to up

R3(config-if)#exit

Part 2: Configure Frame Relay Point-to-Point Subinterfaces
R1(config)#int s0/1/0.102 point
R1(config)#int s0/1/0.102 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.102, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.102, changed state to up

R1(config-subif)#ip address 10.1.1.1 255.255.255.252
R1(config-subif)#bandwidth 64
R1(config-subif)#frame-relay interface-dlci 102
R1(config-subif)#exit

R1(config)#int s0/1/0.103 point-to-point
R1(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.103, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.103, changed state to up

R1(config-subif)#ip address 10.1.3.2 255.255.255.252
R1(config-subif)#bandwidth 64
R1(config-subif)#frame-relay interface-dlci 103
R1(config-subif)#exit
R1(config)#

R2(config)#int s0/1/0.201 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.201, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.201, changed state to up

R2(config-subif)#ip address 10.1.1.2 255.255.255.252
R2(config-subif)#bandwidth 64
R2(config-subif)#frame-relay interface-dlci 201
R2(config-subif)#exit
R2(config)#

R2(config)#int s0/1/0.203 point-to-point
R2(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.203, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.203, changed state to up

R2(config-subif)#ip address 10.1.2.1 255.255.255.252
R2(config-subif)#bandwidth 64
R2(config-subif)#frame-relay interface-dlci 203
R2(config-subif)#exit
R2(config)#

R3(config)#int s0/1/0.301 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.301, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.301, changed state to up

R3(config-subif)#ip address 10.1.3.1 255.255.255.252
R3(config-subif)#bandwidth 64
R3(config-subif)#frame-relay interface-dlci 301
R3(config-subif)#exit
R3(config)#

R3(config)#int s0/1/0.302 point-to-point
R3(config-subif)#
%LINK-5-CHANGED: Interface Serial0/1/0.302, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1/0.302, changed state to up

R3(config-subif)#ip address 10.1.2.2 255.255.255.252
R3(config-subif)#bandwidth 64
R3(config-subif)#frame-relay interface-dlci 302
R3(config-subif)#exit
R3(config)#
Router Configuration :

R1(config)#int g0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shut

R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config)#int g0/0
R2(config-if)#ip address 192.168.30.1 255.255.255.0
R2(config-if)#no shut

R2(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R2(config-if)#exit
R2(config)#

R3(config)#int s0/1/1
R3(config-if)#ip address 209.165.200.225 255.255.255.224
R3(config-if)#no shut

%LINK-5-CHANGED: Interface Serial0/1/1, changed state to down
R3(config-if)#
R3(config-if)#clock rate 64000
R3(config-if)#exit
R3(config)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname ISP
ISP(config)#int s0/3/0
ISP(config-if)#ip address 209.165.200.226 255.255.255.224
ISP(config-if)#no shut

ISP(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

ISP(config-if)#

ISP(config)#int g0/0
ISP(config-if)#ip address 209.165.200.1 255.255.255.252
ISP(config-if)#no shut

ISP(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

ISP(config-if)#
R1(config-if)#router eigrp 1
R1(config-router)#network 10.1.1.0 0.0.0.3
R1(config-router)#network 10.1.3.0 0.0.0.3
R1(config-router)#network 192.168.10.0 0.0.0.255
R1(config-router)#exit
R1(config)#
R2(config)#router eigrp 1
R2(config-router)#network 10.1.1.0 0.0.0.3
R2(config-router)#network 10.1.2.0 0.0.0.3
R2(config-router)#network 192.168.30.0 0.0.0.255
R2(config-router)#exit
R2(config)#

R3(config)#router eigrp 1
R3(config-router)#network 10.1.3.0 0.0.0.3
R3(config-router)#network 10.1.2.0 0.0.0.3
R3(config-router)#network 209.165.200.0 0.0.0.31
R3(config-router)#

Thank you

Momataj Momo

Advertisements

General information about Routers and Routing

Router Memory :

Similar yet different from a regular computer, the router has different kinds of memory ROM, Flash, NVRAM, and SDRAM which all have different functions:

  • ROM – POST, Bootstrap, and ROMMON
  • Flash – IOS
  • NVRAM – Configuration File
  • SDRAM – Running-Config, Routing Table, IOS (everything is loaded and executed from RAM)

The router is a computer but it does not have a traditional hard drive to store files and the operating system, this is accomplished in Flash memory and NVRAM memory.

Router Bootup Process:

  1. POSTROM memory,
  2. BootstrapROM memory,
  3. Load the IOS – the router has an ordered routine for loading the IOS

    1. Flash Memory – the IOS is typically loaded from Flash memory
    2. TFTP – if there is no IOS in Flash, the router will search for a network TFTP server,
    3. ROM – if there is no IOS found, the router defaults to a recovery IOS called Rommon,
  4. Load the Startup-Configthe router has an ordered routine for loading the startup-config file

    1. NVRAM memory – the startup-config file is typically loaded from NVRAM memory
    2. TFTP – if there is no config file in NVRAM, the router will search for a network TFTP server,
    3. Setup-Mode – if there is no configuration file found, the router defaults to setup-mode

The Router’s Purpose:

The router’s purpose or function is to find the best path (route) and switch out of the correct interface. The router will make the decision of the “best path” by first determining the destination network, and second by consulting its routing table.

Static Routing and Dynamic Routing:

Static routing is a good choice for networks that: never change, are small in size or have only one router, or have only one way out of the network.

Dynamic routing is a good choice if a network has multiple routers, is part of a larger network, or if the network changes frequently.

For example, in a situation where the network changes, with a dynamic routing protocol if a network goes down, the routers will inform each other automatically through the routing protocol, and the route will be removed from the routing table; with static routing, if a network goes down, an administrator will have to go in and remove the the static route manually.

Different types of interior gateway routing protocols: RIPv1, RIPv2, EIGRP, and OSPF.

Routed Protocols
TCP/IP
IPX/SPX (Novell – no longer in use)
Apple Talk (Apple – no longer in use)

Routing Protocols
RIP v1 – interior gateway protocol, IETF – RFC1058, open standard
RIP v2 – interior gateway protocol, IETF, open standard
EIGRP – interior gateway protocol, Cisco proprietary
OSPF – interior gateway protocol, IETF, open standard
ISIS – interior gateway protocol
BGP – exterior gateway protocol
Interior Gateway Routing Protocol Types
Distance Vector     Link State  
RIP v1 OSPF (VLSM/CIDR)
RIP v2 (VLSM/CIDR)

ISIS (VLSM/CIDR)

 EIGRP (VLSM/CIDR)

Thank you

Momataj Momo

Virtual local area networks (Vlans) Concepts

A VLAN is a group of logically network devices. such as a set of networked computers and printers for a department or building floor.and can seperate networks “guests” and trusted users traffic. A logically separate subnetwork which device on vlan 20 and Vlan 30 can not communicate without a layer 3 device.

The term VLAN stands for ‘Virtual LAN’ and Cisco defines a VLAN as a broadcast domain. Basically, what that means is that you can segregate certain ports on a single physical switch into logical switches (VLANs).VLAN’s allow a network manager to logically segment a LAN into different broadcast domains. Since this is a logical segmentation and not a physical one, workstations do not have to be physically located together. Users on different floors of the same building, or even in different buildings can now belong to the same LAN.VLAN’s also allow broadcast domains to be defined without using routers. Bridging software is used instead to define which workstations are to be included in the broadcast domain. Routers would only have to be used to communicate between two VLAN’s.Moreover , Virtual LAN. Group of devices on one or more LANs that are configured (using management software) so that they can communicate as if they were attached to the same wire, when in fact they are located on a number of different LAN segments. Because VLANs are based on logical instead of physical connections, they are extremely flexible.

20070725_120904_image001_207817_1285_0 16751

VLAN can do :

-Create smaller broadcast domains, and therefore less wasted bandwidth.
-Increase security, as VLANS are not visible to outside traffice
-Decrease Costs: Building with multile companies can use a single network infrastructure.
-Effecient use of bandwidth (2 trunks for a high traffic VlAN)
-Simplify management
– VLANs can also be used to help route traffice. A seperate VLAN can used for VoIP phones.
-It is also possible to seperate Wireless traffic using Wireless VLANs
– Unsecured traffic could be on a ” guest” VLAN
– Secure traffic could be on nn”Staff” VLAN

Types of Connections : 

Devices on a VLAN can be connected in three ways based on whether the connected devices are VLAN-aware or VLAN-unaware. Recall that a VLAN-aware device is one which understands VLAN memberships (i.e. which users belong to a VLAN) and VLAN formats.

1) Trunk Link: All the devices connected to a trunk link, including workstations, must be VLAN-aware. All frames on a trunk link must have a special header attached. These special frames are called tagged frames.

pic3

2) Access Link

An access link connects a VLAN-unaware device to the port of a VLAN-aware bridge. All frames on access links must be implicitly tagged (untagged).The VLAN-unaware device can be a LAN segment with VLAN-unaware workstations or it can be a number of LAN segments containing VLAN-unaware devices

pic4

3) Hybrid Link

This is a combination of the previous two links. This is a link where both VLAN-aware and VLAN-unaware devices are attached. A hybrid link can have both tagged and untagged frames, but allthe frames for a specific VLAN must be either tagged or untagged.

pic5

How to Add VLAN TO network:
Using the CL1, we enter the following on Switch: Lets it CORE1 Switch
CORE1(config) # vlan 10
CORE1(config-vlan) # name student
CORE1(config-vlan) #exit
CORE1(config) #vlan 20
CORE1(config-vlan) # name Faculty
CORE1(config-vlan) #exit
CORE1(config) #vlan 30
CORE1(config-vlan) #name struff
CORE1(config-vlan) #exit
CORE1(config) #vlan40
CORE1(config-vlan) #name guest
CORE1(config-vlan) # exit

VLANs Configuring Ports:
On each switch, identify which device is supposed to be on which VLAN. Suppose,  Student_server_core needs to be on VLAN 10. It is connected to fast ethernet interface 0/2

SWITCH(config)# int fa0/2
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 20
SWITCH(config-if)# exit

* Do the same on all switches , setting the correct ports to the correct VLAN. On the device end, the only note is that all devices on a VLAN must be on the same subnet.

Trunk Link: A trunk is a point to point link between the device and another networking device. Trunk carry the traffic of multiple VLANs over single link and allow user to extend VLAN access on entire network. By default, A trunk port send traffic to add receives from all VLANS. All VLAN IDs are allowed on each trunk.

Configuration syntax for Trunk link:

Switch(config)#vlan 99

Switch(config -vlan)#exit

Switch#config t

SWITCH(config) # Interface fa0/1

Switch(config -if)# switchport mode trunk

Switch(config -if)# Switchport access trunk native vlan 99

Native VLAN: A native vlan is the untagged vlan on an 802.1q trunked switchport.  The native vlan and management vlan could be the same, but it is better security practice that they aren’t.  Basically if a switch receives untagged frames on a trunkport, they are assumed to be part of the vlan that are designated on the switchport as the native vlan.  Frames egressing a switchport on the native vlan are not tagged.

Thank you

Momataj Momo

IPv6 address Fundamental knowledge (part -1)

An IPv6 address is a 128 bit binary number and expressed in hexadecimal form, e.g.

 2001:1234:5678:0001:0000:0000:0000:0001/64 (32 hexadecimal numbers) There is a colon between each 4 hexadecimal numbers. This is for easy reading, just like the “dot-decimal form” of IPv4 address. E.g. 202.175.3.3/64 means the first 64 bit is the network prefix, it is similar to IPv4 CIDR (Classless Inter-Domain Routing) notation 

  • Simplifying IPv6 addresses

Since it is too long to express the IPv6 address, we want to simply it.e.g. 2001:1234:5678:0001:0000:0000:0000:0001/64 can be simplified as 2001:1234:5678:1:0:0:0:1/64 

This is called “Zero compression” – The leading zeros in each segment can be omitted. Continuous zeroes can be further compressed.

2001:1234:5678:0001:0000:0000:0000:0001/64

  • 2001:1234:5678:1:0:0:0:1/64
  • 2001:1234:5678:1::1/64

“::” – Double Colon, means a series of 0000 groups. Since the total length of an IPv6 address is 128 bit, the number of zeroes omitted can be calculated.

 Another example:2001:0000:0000:0001:0000:0000:0000:0001/64

  • 2001:0:0:1:0:0:0:1/64
  • 2001:0:0:1::1/64
  • But Note: 2001::1::1/64 is incorrect. It is because there is no way to identify the no. of zeroes omitted in the two double-colon areas.
  • IPv6 Prefix  Let’s learn more about IPv6 Prefix. 

In IPv4, we use subnet mask to denote the network portion.

e.g. 192.168.1.1 255.255.255.0 à 192.168.1.0 is the network portion

It can be written as : 192.168.1.1/24  (CIDR notation) In IPv6, we don’t use subnet mask. We only use the latter CIDR notation e.g.

2001:1234:5678:0001:0000:0000:0000:0001/64 

The network portion is : 2001:1234:5678:0001::  /64

The host portion is : 0000:0000:0000:0001. 

That means there can be a tremendous number of hosts, 264.

In IPv6, the network portion of an IP address is basically fixed at /64 and the host portion is always 64 bits.There is no need for subnetting. Since there are far too many bits in the IPv6 addresses that each organization can be assigned a network prefix of /48.e.g. A company may be assigned range of IP addresses with a network prefix of 2001:1234:5678:: /48. Then, the company can use 16 bits for the local subnetting.e.g. 

2001:1234:5678:0000::   /64 is the first subnet

to

2001:1234:5678:FFFF::   /64 is the last subnet. This results in 65536 subnets, which is far more than enough for each company or organization. In each subnet, there can be  2^64 hosts.So, the network prefix of a usable IPv6 address is basically fixed at /64 and no further subnetting is needed. This is an advantage over IPv4 because we need to do quite a lot troublesome IP address subnetting in IPv4. 

  • Demonstration

Let’s use Packet Tracer to show a demonstration of using IPv6 addresses. 

Topology: 

                                       

IPV^6

Fig: Example of Topology for IPv6

PC setting:

 IPv6_pc

Router setting:

 ipv6_router

Ping test:

ipv6_ping

                                Different kinds of IPv6 addresses

  • IPv6 Global Unicast AddressI

IP addresses are allocated by IANA (Internet Assigned Numbers Authority), through 5 RIRs (Regional Internet Registries), which are responsible for 5 different areas on the Earth.

ipv6_7

                                                          Regional Internet Registries

The current allocation of public IPv4 addresses is not sequential and continuous, meaning that a geographic region may acquire discontinuous ranges of public IPv4 address. This is due to the historical way of assignment and the insufficient public IPv4 addresses. E.g. For Macau region, it contains a large number of discontinuous, small address ranges, starting with 202.175.x, 27.x.y, 60.x.y, 113.x.y etc. This makes the aggregation of public IPv4 addresses very inefficient.

For IPv6, since it is a new deployment and there are huge numbers of IPv6 addresses. Huge enough to give each piece of sand on the Earth an IPv6 address. So, the assignment of public IPv6 addresses is more systematic. 

Currently only 1/8 of the IPv6 addresses are publicly assigned, which is :

2000::/3. What does it means? 

It means from 2000:: to 3FFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF

 

0010  0000  0000  0000  0000 0000 …. 0000 0000  

2      0     0    0   : 0000:0000:0000:0000:0000:0000:0000 

(Binary)

(Hexadecimal)

0011  1111  1111  1111  1111 1111 …. 1111 1111

3      F     F     F  : FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF

(Binary)

(Hexadecimal)

And, currently, most of the assigned public IPv6 addresses starts with 2001::/16.

0010  0000  0000  0001  … … … … … … …… … … … … … … … … … … … … …

2     0     0     1   : … … … … … … …… … … … … … … … … … … … …

(Binary)

(Hexadecimal)

The IANA assigns address blocks to the five RIRs. The following table shows only a small portion of them. Usually, the IANA assigns address block with /23 prefix. 

2001:0200::/23

APNIC

 

2001:0400::/23

ARIN

2001:0600::/23

RIPE NCC

 

2001:1200::/23

LACNIC

2001:4200::/23

AFRINIC

   
ipv6_8

                                                                Fig: IANA

 

So, APNIC has got this block of IPv6 addresses:

 ipv_9

 Then, the APNIC assigns address blocks to ISPs.

e.g. APNIC may assign a block of addresses to ISPs like this : 

2001:02 55::/32  to ISPa

2001:02 66::/32  to ISPb 

So, ISPa gets a block of IP addresses as follows: 

ipv10

                           fig : ISPa gets a block of IP addresses

ipv11

                            fig: ISPa assigns blocks of IP addresses to different organization

In this point of view, Organization A is referred to as a Site.Now, the organization can freely use the remaining bits for its own, but, keeping 16 bits for Subnet ID. 

i.e. From 2001:0255:8888:0000::/64 to 2001:0255:8888:FFFF::/64 (The yellow portion is used as Subnet ID.)Then, for each subnet, there are 64 bits for hosts, all together, 2^64 hosts. This is called Interface ID and is used for identifying IPv6 host interface.  

ip_v_6_aa

                                                      fig: IPv6 host interface

 As one organization can have 65536 subnets, with each subnet having 264 hosts, this is far more than enough. So, no more subnetting is needed by the organization.

 The above resultant IPv6 addresses is publicly reachable in the Internet and is called :

1. IPv6 Global Unicast Address . It is similar to the IPv4 public addresses.

ip_7_v

                                                   fig: IPv6 Global Unicast Address

 2. IPv6 Link local (Unicast) Address   In IPv6, a network host will try to discover if there is any neighbor nearby.e.g. PC-A may send out a message like this:

ipv6_mu

fig: IPv6 Link local (Unicast) Address (PC-A may send out a message)

And PC-B may reply:

pc-reply

fig: IPv6 Link local (Unicast) Address (PC -B Reply)

You will notice that they are not using their Global Unicast address. Instead, they use a kind of IPv6 address called: “Link Local address”. In IPv6, Link Local address is used to communicate with neighbors in the same link or Layer 2 segment.

How is the Link Local address formed?

link local1

                                             fig: How is the Link Local address formed?

link local11

                                                        fig: How is the Link Local address formed?

The Link Local address is automatically generated, even though the interface has not been assigned with any IPv6 Global Unicast Address. IPv6 Link Local address is analogous to IPv4 Link Local address, in the range : 169.254.0.0/16. But, their usage is different. An IPv4 host will only get such an address when it is configured to use DHCP server to acquire IP address but no response from any DHCP server is got.

 

Thank you 

Momataj Momo

Description of Network Layer and related layers

In the seven-layer OSI model of computer networking, the network layer is layer 3. The network layer is responsible for packet forwarding including routing through intermediate routers, whereas the data link layer is responsible for media access control, flow control and error checking.It is work with IP protocol and default device is router.

Functions: 

The network layer provides the functional and procedural means of transferring variable-length data sequences from a source to a destination host via one or more networks, while maintaining the quality of service functions.

Functions of the network layer include:

  • Connection model: connectionless communication
    For example, IP is connectionless, in that a datagram can travel from a sender to a recipient without the recipient having to send an acknowledgement. Connection-oriented protocols exist at other, higher layers of the OSI model.
  • Host addressing: Every host in the network must have a unique address that determines where it is. This address is normally assigned from a hierarchical system.. On the Internet, addresses are known as Internet Protocol (IP) addresses.
  • Message Forwarding : Since many networks are partitioned into subnetworks and connect to other networks for wide-area communications, networks use specialized hosts, called gateways or routers, to forward packets between networks. This is also of interest to mobile applications, where a user may move from one location to another, and it must be arranged that his messages follow him. Version 4 of the Internet Protocol (IPv4) was not designed with this feature in mind, although mobility extensions exist. IPv6 has a better designed solution.

OSI network architecture, the network layer responds to service requests from the transport layer and issues service requests to the data link layer.

Transport layer to physical layer data forwarding system: 

Tansport

Fig: Data sent in transport layer

network layer

Fig: Packet forwarding in network layer

datalink

Fig: Frame send in Data link layer

physcial

Fig: Frame become single after come physical layer

A cyclic redundancy check (CRC) is an error-detecting code commonly used in digital networks and storage devices to detect accidental changes to raw data. Blocks of data entering these systems get a short check value attached, based on the remainder of a polynomial division of their contents; on retrieval the calculation is repeated, and corrective action can be taken against presumed data corruption if the check values do not match.

CRCs are so called because the check (data verification) value is a redundancy (it expands the message without adding information) and the algorithm is based on cyclic codes. 

Two kind of Data packet sent in network layer:

a) User Datagram Protocol (UDP): UPDThe User Datagram Protocol (UDP) is one of the core members of the Internet Protocol Suite, the set of network protocols used for the Internet. With UDP, computer applications can send messages, in this case referred to as datagrams, to other hosts on an Internet Protocol (IP) network without requiring prior communications to set up special transmission channels or data paths.

Data Structure of UDP:

  • UDP is a minimal message-oriented Transport Layer protocol that is documented in IETF RFC 768.
  • UDP provides no guarantees to the upper layer protocol for message delivery and the UDP protocol layer retains no state of UDP messages once sent. For this reason, UDP sometimes is referred to as Unreliable Datagram Protocol.
  • UDP provides application multiplexing (via port numbers) and integrity verification (via checksum) of the header and payload. If transmission reliability is desired, it must be implemented in the user’s application.
  • The UDP header consists of 4 fields, each of which is 2 bytes (16 bits).The use of the fields “Checksum” and “Source port” is optional in IPv4 (pink background in table). In IPv6 only the source port is optional.
  • When UDP runs over IPv4, the checksum is computed using a “pseudo header” that contains some of the same information from the real IPv4 header. The pseudo header is not the real IPv4 header used to send an IP packet, it is used only for the checksum calculation.
  • When UDP runs over IPv6, the checksum is mandatory. The method used to compute it is changed as documented in RFC 2460

Most often, UDP applications do not employ reliability mechanisms and may even be hindered by them. Streaming media, real-time multiplayer games and voice over IP (VoIP) are examples of applications that often use UDP. In these particular applications, loss of packets is not usually a fatal problem. If an application requires a high degree of reliability, a protocol such as the Transmission Control Protocol may be used instead.

b) Protocol Data unit (PDU):PDU Information that is delivered as a unit among peer entities of a network and that may contain control information, address information, or data.

PDUs are relevant in relation to each of the first 4 layers of the OSI model as follows:

The Layer 1 (Physical Layer) PDU is the packet, consisting of bits or, more generally, symbols (can also be seen as “stream”)
The Layer 2 (Data Link Layer) PDU is the frame
The Layer 3 (Network Layer) PDU is the packet
The Layer 4 (Transport Layer) PDU is the segment for TCP, or the datagram for UDP
The Layer 5-6-7 (Application Layer) PDU is the message
Given a context pertaining to a specific OSI layer, PDU is sometimes used as a synonym for its representation at that layer.

Thank you

Momataj Momo