OSPFV2 Multi area Technology ( Configuration )

OSPFV2 Multi area configuration

OSPFV2 Multi area configuration

Router R1:

R1(config)#: interface GigabitEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config)#: interface GigabitEthernet0/1
R1(config-if)#ip address 10.1.2.1 255.255.255.0

R1(config)#: interface Serial0/3/0
R1(config-if)#ip address 192.168.10.1 255.255.255.252
R1(config-if)#clock rate 64000

OSPFV2 Configuration Command:

R1(config)#router ospf 10
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.1.1.1 0.0.0.0 area 1
R1(config-router)#network 10.1.2.1 0.0.0.0 area 1
R1(config-router)#network 192.168.10.1 0.0.0.0 area 0
R1(config-router)#

Summarizing OSPF: 

R1(config)#router ospf 10

R1(config-router)#area 1 range 10.1.0.0 255.255.252.0
Router R2:

R2(config)#interface Serial0/3/0
R2(config-if)#ip address 192.168.10.2 255.255.255.252
R2(config)#

R2(config)#interface Serial0/3/1
R2(config-if)#ip address 192.168.10.5 255.255.255.252
R2(config-if)clock rate 64000

R2(config)#router ospf 10
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#network 192.168.10.4 0.0.0.3 area 0
R2(config-router)#
Router R3:

R3(config)#interface GigabitEthernet0/0
R3(config-if)# ip address 192.168.1.1 255.255.255.0

R3(config)#interface GigabitEthernet0/1
R3(config-if)# ip address 192.168.2.1 255.255.255.0
R3(config)#interface Serial0/3/1
R3(config-if)#ip address 192.168.10.6 255.255.255.252
Router(config)#hostname R3
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.10.6 0.0.0.0 area 0
R3(config-router)#network 192.168.1.1 0.0.0.0 area 2

R3(config-router)#network 192.168.2.1 0.0.0.0 area 2
R3(config-router)#end

Summarizing OSPF: 

R2(config)#router ospf 10

R2(config-router)#area 2 range 192.168.0.0 255.255.252.0

Verification and Troubleshooting Command:

R3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:38 192.168.10.5 Serial0/3/1
R3#
R3#
R3#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 1.1.1.1 [128] via 192.168.10.5, Serial0/3/1, ABR, Area 0, SPF 128
R3#
R1#show ip ospf interface

R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:30 192.168.10.2 Serial0/3/0
R1#

R1#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 3.3.3.3 [128] via 192.168.10.2, Serial0/3/0, ABR, Area 0, SPF 128
R1#
R1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 239 0x80000002 0x00ffcf 2
2.2.2.2 2.2.2.2 164 0x80000004 0x00bc75 4
3.3.3.3 3.3.3.3 144 0x80000003 0x0004b1 2

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 284 0x80000001 0x00db72
10.1.2.0 1.1.1.1 284 0x80000002 0x00ce7d
192.168.1.0 3.3.3.3 139 0x80000001 0x007c6b
192.168.2.0 3.3.3.3 119 0x80000002 0x006f76

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 288 0x80000003 0x008f8f 2

Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.10.0 1.1.1.1 284 0x80000001 0x00bbee
192.168.10.4 1.1.1.1 219 0x80000002 0x001451
192.168.1.0 1.1.1.1 134 0x80000003 0x00b9b3
192.168.2.0 1.1.1.1 114 0x80000004 0x00acbe
R1#

R1#show ip route ospf
O IA 192.168.1.0 [110/129] via 192.168.10.2, 00:04:37, Serial0/3/0
O IA 192.168.2.0 [110/129] via 192.168.10.2, 00:04:17, Serial0/3/0
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O 192.168.10.4 [110/128] via 192.168.10.2, 00:06:03, Serial0/3/0
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ – 00:00:31 192.168.10.1 Serial0/3/0
3.3.3.3 0 FULL/ – 00:00:34 192.168.10.6 Serial0/3/1
R2#

R2#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 1.1.1.1 [64] via 192.168.10.1, Serial0/3/0, ABR, Area 0, SPF 64
i 3.3.3.3 [64] via 192.168.10.6, Serial0/3/1, ABR, Area 0, SPF 64
R2#

R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 304 0x80000002 0x00ffcf 2
2.2.2.2 2.2.2.2 230 0x80000004 0x00bc75 4
3.3.3.3 3.3.3.3 209 0x80000003 0x0004b1 2

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 349 0x80000001 0x00db72
10.1.2.0 1.1.1.1 349 0x80000002 0x00ce7d
192.168.1.0 3.3.3.3 204 0x80000001 0x007c6b
192.168.2.0 3.3.3.3 184 0x80000002 0x006f76
R2#

List of verification command:

R1# show Ip route OSPF
R1#show IP OSPF NEIGHBOR
R1#SHOW IP OSPF
R1#SHOW IP OSPF INTERFACE
R1#SHOW IP PROTOCOLS
R1#SHOW IP OSPF INTERFACE BRIEF
R1#SHOW IP OSPF DATABASE
R1#SHOW IP OSF BORDER-ROUTERS

Summarizing OSPF verification Command:

R3#show ip route ospf

10.0.0.0/22 is subnetted, 1 subnets

O IA 10.1.0.0 [110/129] via 192.168.10.5, 00:00:55, Serial0/3/1

192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks

O 192.168.10.0 [110/128] via 192.168.10.5, 00:01:05, Serial0/3/1

R3#

Thank you

Momataj Momo

Advertisements

Practical : Simple EIGRP Configuration

EIGRP 2

EIGRP Topology

Configuration Command line for EIGRP 

R1(config)#router eigrp 1
R1(config-router)#network 192.168.5.0 0.0.0.127
R1(config-router)#network 192.168.5.224 0.0.0.3
R1(config-router)#network 192.168.5.228 0.0.0.3
R1(config-router)#redistribute static
R1(config-router)#no auto-summary
R1(config-router)#end
R1#show ip eigrp topology
R1#show ip eigrp topology all-links
R1#show ip eigrp neighbors
R0(config)#int s2/0
R0(config-if)#bandwidth 64

network 1: 192.168.5.0 – .127 /25
network 2: 192.168.5.128 – .191 /26
network 3: 192.168.5.192 – .223 /27
network 4: 192.168.5.224 – .227 /30
network 5: 192.168.5.228 – .231 /30
network 6: 192.168.5.232 – .235 /30

wildcard bits subtractor
255.255.255.255
255.255.255.224
———————
0.0.0.31
R1>

interface FastEthernet0/0
ip address 192.168.5.1 255.255.255.128
interface Serial2/0
ip address 192.168.5.229 255.255.255.252
interface Serial3/0
ip address 192.168.5.226 255.255.255.252
clock rate 64000

router eigrp 1
network 192.168.5.0 0.0.0.127
network 192.168.5.224 0.0.0.3
network 192.168.5.228 0.0.0.3
no auto-summary
R2>

interface FastEthernet0/0
ip address 192.168.5.129 255.255.255.192

interface Serial2/0
ip address 192.168.5.225 255.255.255.252

interface Serial3/0
ip address 192.168.5.234 255.255.255.252
clock rate 64000
NO Shutdown

router eigrp 1
network 192.168.5.128 0.0.0.63
network 192.168.5.224 0.0.0.3
network 192.168.5.232 0.0.0.3
NO auto-summary

R3>

interface FastEthernet0/0
ip address 192.168.5.193 255.255.255.224
interface Serial3/0
ip address 192.168.5.230 255.255.255.252
clock rate 64000
router eigrp 1
network 192.168.5.192 0.0.0.31
network 192.168.5.232 0.0.0.3
network 192.168.5.228 0.0.0.3
No auto-summary

Thank you

Momataj Momo

Practical : Simple RIP Configuration

RIP

RIP Topology

RIP Configuration Command Line:

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R1
R1(config)#enable secret cisco
R1(config)#enable password cisco
The enable password you have chosen is the same as your enable secret.
This is not recommended. Re-enter the enable password.
R1(config)#service password-encryption
R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit
R1(config)#line vty 0 15
R1(config-line)#pass cisco
R1(config-line)#login
R1(config-line)#exit

R1(config)#int fa0/0
R1(config-if)#ip address 192.168.10.1 255.255.255.0
R1(config-if)#no shutdown

R1(config-if)#exit
R1(config)#int s0/1/0
R1(config-if)#ip address 10.10.10.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/1/0, changed state to down
R1(config-if)#
R1(config-if)#

R1(config)#router rip
R1(config-router)#network 192.168.10.0
R1(config-router)#network 10.10.10.0
R1(config-router)#exit
R1(config)#
Switch>
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
SWITCH1(config)#hostname SWITCH1
SWITCH1(config)#
SWITCH1(config)#enable password cisco
SWITCH1(config)#enable secret cisco
The enable secret you have chosen is the same as your enable password.
This is not recommended. Re-enter the enable secret.
SWITCH1(config)#line console 0
SWITCH1(config-line)#password cisco
SWITCH1(config-line)#login
SWITCH1(config-line)#exit
SWITCH1(config)#line vty 0 15
SWITCH1(config-line)#password cisco
SWITCH1(config-line)#login
SWITCH1(config-line)#exit
SWITCH1(config)#banner motd “HELLO WORLD”
SWITCH1(config)#

SWITCH1(config)#vlan 30
SWITCH1(config-vlan)#int vlan 30
SWITCH1(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up
SWITCH1(config-if)#ip address 192.168.10.2 255.255.255.0
SWITCH1(config-if)#no shutdown
SWITCH1(config-if)#exit
SWITCH1(config)#
Switch>en
Switch#config t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#enable password cisco
SWITCH(config)#hostname SWITCH2
Switch2(config)#enable secret cisco
The enable secret you have chosen is the same as your enable password.
This is not recommended. Re-enter the enable secret.
Switch2(config)#
Switch2(config)#service password-encryption
Switch2(config)#line console 0
Switch2(config-line)#password cisco
Switch2(config-line)#login
Switch2(config-line)#exit
Switch2(config)#line vty 0 15
Switch2(config-line)#password cisco
Switch2(config-line)#login
Switch2(config-line)#exit
Switch2(config)#banner motd “HELLO WORLD”
Switch2(config)#

Switch2(config)#vlan 30
Switch2(config-vlan)#int vlan 30
Switch2(config-if)#
%LINK-5-CHANGED: Interface Vlan30, changed state to up

Switch2(config-if)#ip address 172.16.0.2 255.255.0.0
Switch2(config-if)#no shutdown
Switch2(config-if)#exit
Switch2(config)#
Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2
R2(config)#
Router(config)#hostname R2
R2(config)#enable password cisco
R2(config)#enable secret cisco
The enable secret you have chosen is the same as your enable password.
This is not recommended. Re-enter the enable secret.
R2(config)#service password-encryption
R2(config)#line console 0
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#line vty 0 15
R2(config-line)#password cisco
R2(config-line)#login
R2(config-line)#exit
R2(config)#

R2(config)#int fa0/0
R2(config-if)#ip address 172.16.0.1 255.255.0.0
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#

R2(config-if)#exit
R2(config)#int s0/1/0
R2(config-if)#ip address 10.10.10.2 255.0.0.0
R2(config-if)#no shutdown

R2(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

R2(config-if)#
R2(config)#router rip
R2(config-router)#network 172.16.0.0

R2(config-router)#network 10.10.10.0
R2(config-router)#exit
R2(config)#

PC>ping 192.168.10.5

Thank you

Momataj Momo

Practical : Simple OSPF Configuration

OSPF SIMPLE PRACTICS

OSPF Ttopology

Configuration Command on Router 0:
NETA>
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
NO shutdown
interface Serial0/3/0
ip address 172.16.1.1 255.255.255.252
clock rate 64000
NO shutdown
router ospf 10
network 192.168.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0
Configuration Command on Router 1:
NETC>
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
NO shutdown

interface Serial0/3/0
ip address 172.16.1.2 255.255.255.252
NO shutdown

interface Serial0/3/1
ip address 200.100.50.1 255.255.255.252
clock rate 64000
NO shutdown

router ospf 20

network 172.16.1.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.255 area 0
network 200.100.50.0 0.0.0.3 area 0

Configurations Command on Router 3:
NETC>

interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
NO SHUTDOWN
interface Serial0/3/0
ip address 200.100.50.2 255.255.255.252
NO SHUTDOWN

router ospf 30
network 198.168.3.0 0.0.0.255 area 0
network 200.100.50.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.255 area 0

Thank you

Momataj Momo

How to Configure OSPF in CISCO

OSPF Tropology

OSPF Tropology

Configuration Command Line on R2:

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int g0/0
Router(config-if)#ip address 172.16.0.193 255.255.255.224
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

Router(config-if)#
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int s0/3/0
Router(config-if)#ip address 172.16.0.226 255.255.255.252
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/3/0, changed state to down
Router(config-if)#exit
Router(config)#int s0/3/1
Router(config-if)#ip address 172.16.0.229 255.255.255.252
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/3/1, changed state to down
Router(config-if)#
Router(config-if)#
Router(config-if)#exit

Router(config)#router ospf 1
Router(config-router)#network 172.16.0.192 0.0.0.31 area 0
Router(config-router)#network 172.16.0.224 0.0.0.3 area 0
Router(config-router)#network 172.16.0.228 0.0.0.3 area 0
Router(config-router)#passive-interface g0/0

Router#show ip ospf int g0/0
Router#show ip ospf

Configuration Command Line on R1:

Router(config)#hostname R1
R1(config)#
R1(config-if)#int g0/0
R1(config-if)#ip address 172.16.0.1 255.255.255.128
R1(config-if)#no shutdown

R1(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R1(config-if)#exit
R1(config-if)#exit
R1(config)#int s0/1/0
R1(config-if)#ip address 172.16.0.225 255.255.255.252
R1(config-if)#clock rate 64000
R1(config-if)#no shutdown

R1(config-if)#
%LINK-5-CHANGED: Interface Serial0/1/0, changed state to up

R1(config-if)#exit
R1(config)#int s0/1/1
R1(config-if)#ip address 172.16.0.234 255.255.255.252
R1(config-if)#no shutdown

R1(config-if)#router ospf 1
R1(config-router)#network 172.16.0.0 0.0.0.127
% Incomplete command.
R1(config-router)#network 172.16.0.0 0.0.0.127 area 0
R1(config-router)#network 172.16.0.224 0.0.0.3 area 0
R1(config-router)#network 172.16.0.232 0.0.0.3 area 0
R1(config-router)#exit
Router(config-router)#

Configuration Command Line on R3:

Router>en
Router#config t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R3
R3#config t
Enter configuration commands, one per line. End with CNTL/Z.
R3(config)#int g0/0
R3(config-if)#ip address 172.16.0.129 255.255.255.192
R3(config-if)#no shutdown
R3(config-if)#
R3(config-if)#

R3(config-if)#
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up

R3(config-if)#exit
R3(config)#int s0/3/1
R3(config-if)#ip address 172.16.0.230 255.255.255.252
R3(config-if)#no shutdown

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/1, changed state to up
R3(config-if)#exit
R3(config)#int
% Incomplete command.
R3(config)#int s0/3/0
R3(config-if)#ip address 172.16.0.233 255.255.255.252
R3(config-if)#clock rate 64000
R3(config-if)#no shutdown

R3(config-if)#
%LINK-5-CHANGED: Interface Serial0/3/0, changed state to up

R3(config-if)#exit
R3(config)#

R3(config)#router ospf 1
R3(config-router)#network 172.16.0.128 0.0.0.63 area 0
R3(config-router)#network 172.16.0.228 0.0.0.3 area 0

R3(config-router)#network 172.16.0.232 0.0.0.3 area 0
R3(config-router)#exit

Now Test the connection through PC: 

PC>ping 172.16.0.194

Pinging 172.16.0.194 with 32 bytes of data:

Request timed out.
Reply from 172.16.0.194: bytes=32 time=1ms TTL=126
Reply from 172.16.0.194: bytes=32 time=2ms TTL=126
Reply from 172.16.0.194: bytes=32 time=1ms TTL=126

ping test

Ping Testing

Thank you

Momataj Momo

Virtual local area networks (Vlans) Concepts

A VLAN is a group of logically network devices. such as a set of networked computers and printers for a department or building floor.and can seperate networks “guests” and trusted users traffic. A logically separate subnetwork which device on vlan 20 and Vlan 30 can not communicate without a layer 3 device.

The term VLAN stands for ‘Virtual LAN’ and Cisco defines a VLAN as a broadcast domain. Basically, what that means is that you can segregate certain ports on a single physical switch into logical switches (VLANs).VLAN’s allow a network manager to logically segment a LAN into different broadcast domains. Since this is a logical segmentation and not a physical one, workstations do not have to be physically located together. Users on different floors of the same building, or even in different buildings can now belong to the same LAN.VLAN’s also allow broadcast domains to be defined without using routers. Bridging software is used instead to define which workstations are to be included in the broadcast domain. Routers would only have to be used to communicate between two VLAN’s.Moreover , Virtual LAN. Group of devices on one or more LANs that are configured (using management software) so that they can communicate as if they were attached to the same wire, when in fact they are located on a number of different LAN segments. Because VLANs are based on logical instead of physical connections, they are extremely flexible.

20070725_120904_image001_207817_1285_0 16751

VLAN can do :

-Create smaller broadcast domains, and therefore less wasted bandwidth.
-Increase security, as VLANS are not visible to outside traffice
-Decrease Costs: Building with multile companies can use a single network infrastructure.
-Effecient use of bandwidth (2 trunks for a high traffic VlAN)
-Simplify management
– VLANs can also be used to help route traffice. A seperate VLAN can used for VoIP phones.
-It is also possible to seperate Wireless traffic using Wireless VLANs
– Unsecured traffic could be on a ” guest” VLAN
– Secure traffic could be on nn”Staff” VLAN

Types of Connections : 

Devices on a VLAN can be connected in three ways based on whether the connected devices are VLAN-aware or VLAN-unaware. Recall that a VLAN-aware device is one which understands VLAN memberships (i.e. which users belong to a VLAN) and VLAN formats.

1) Trunk Link: All the devices connected to a trunk link, including workstations, must be VLAN-aware. All frames on a trunk link must have a special header attached. These special frames are called tagged frames.

pic3

2) Access Link

An access link connects a VLAN-unaware device to the port of a VLAN-aware bridge. All frames on access links must be implicitly tagged (untagged).The VLAN-unaware device can be a LAN segment with VLAN-unaware workstations or it can be a number of LAN segments containing VLAN-unaware devices

pic4

3) Hybrid Link

This is a combination of the previous two links. This is a link where both VLAN-aware and VLAN-unaware devices are attached. A hybrid link can have both tagged and untagged frames, but allthe frames for a specific VLAN must be either tagged or untagged.

pic5

How to Add VLAN TO network:
Using the CL1, we enter the following on Switch: Lets it CORE1 Switch
CORE1(config) # vlan 10
CORE1(config-vlan) # name student
CORE1(config-vlan) #exit
CORE1(config) #vlan 20
CORE1(config-vlan) # name Faculty
CORE1(config-vlan) #exit
CORE1(config) #vlan 30
CORE1(config-vlan) #name struff
CORE1(config-vlan) #exit
CORE1(config) #vlan40
CORE1(config-vlan) #name guest
CORE1(config-vlan) # exit

VLANs Configuring Ports:
On each switch, identify which device is supposed to be on which VLAN. Suppose,  Student_server_core needs to be on VLAN 10. It is connected to fast ethernet interface 0/2

SWITCH(config)# int fa0/2
SWITCH(config-if)# switchport mode access
SWITCH(config-if)# switchport access vlan 20
SWITCH(config-if)# exit

* Do the same on all switches , setting the correct ports to the correct VLAN. On the device end, the only note is that all devices on a VLAN must be on the same subnet.

Trunk Link: A trunk is a point to point link between the device and another networking device. Trunk carry the traffic of multiple VLANs over single link and allow user to extend VLAN access on entire network. By default, A trunk port send traffic to add receives from all VLANS. All VLAN IDs are allowed on each trunk.

Configuration syntax for Trunk link:

Switch(config)#vlan 99

Switch(config -vlan)#exit

Switch#config t

SWITCH(config) # Interface fa0/1

Switch(config -if)# switchport mode trunk

Switch(config -if)# Switchport access trunk native vlan 99

Native VLAN: A native vlan is the untagged vlan on an 802.1q trunked switchport.  The native vlan and management vlan could be the same, but it is better security practice that they aren’t.  Basically if a switch receives untagged frames on a trunkport, they are assumed to be part of the vlan that are designated on the switchport as the native vlan.  Frames egressing a switchport on the native vlan are not tagged.

Thank you

Momataj Momo

IPv6 address Fundamental knowledge (part -1)

An IPv6 address is a 128 bit binary number and expressed in hexadecimal form, e.g.

 2001:1234:5678:0001:0000:0000:0000:0001/64 (32 hexadecimal numbers) There is a colon between each 4 hexadecimal numbers. This is for easy reading, just like the “dot-decimal form” of IPv4 address. E.g. 202.175.3.3/64 means the first 64 bit is the network prefix, it is similar to IPv4 CIDR (Classless Inter-Domain Routing) notation 

  • Simplifying IPv6 addresses

Since it is too long to express the IPv6 address, we want to simply it.e.g. 2001:1234:5678:0001:0000:0000:0000:0001/64 can be simplified as 2001:1234:5678:1:0:0:0:1/64 

This is called “Zero compression” – The leading zeros in each segment can be omitted. Continuous zeroes can be further compressed.

2001:1234:5678:0001:0000:0000:0000:0001/64

  • 2001:1234:5678:1:0:0:0:1/64
  • 2001:1234:5678:1::1/64

“::” – Double Colon, means a series of 0000 groups. Since the total length of an IPv6 address is 128 bit, the number of zeroes omitted can be calculated.

 Another example:2001:0000:0000:0001:0000:0000:0000:0001/64

  • 2001:0:0:1:0:0:0:1/64
  • 2001:0:0:1::1/64
  • But Note: 2001::1::1/64 is incorrect. It is because there is no way to identify the no. of zeroes omitted in the two double-colon areas.
  • IPv6 Prefix  Let’s learn more about IPv6 Prefix. 

In IPv4, we use subnet mask to denote the network portion.

e.g. 192.168.1.1 255.255.255.0 à 192.168.1.0 is the network portion

It can be written as : 192.168.1.1/24  (CIDR notation) In IPv6, we don’t use subnet mask. We only use the latter CIDR notation e.g.

2001:1234:5678:0001:0000:0000:0000:0001/64 

The network portion is : 2001:1234:5678:0001::  /64

The host portion is : 0000:0000:0000:0001. 

That means there can be a tremendous number of hosts, 264.

In IPv6, the network portion of an IP address is basically fixed at /64 and the host portion is always 64 bits.There is no need for subnetting. Since there are far too many bits in the IPv6 addresses that each organization can be assigned a network prefix of /48.e.g. A company may be assigned range of IP addresses with a network prefix of 2001:1234:5678:: /48. Then, the company can use 16 bits for the local subnetting.e.g. 

2001:1234:5678:0000::   /64 is the first subnet

to

2001:1234:5678:FFFF::   /64 is the last subnet. This results in 65536 subnets, which is far more than enough for each company or organization. In each subnet, there can be  2^64 hosts.So, the network prefix of a usable IPv6 address is basically fixed at /64 and no further subnetting is needed. This is an advantage over IPv4 because we need to do quite a lot troublesome IP address subnetting in IPv4. 

  • Demonstration

Let’s use Packet Tracer to show a demonstration of using IPv6 addresses. 

Topology: 

                                       

IPV^6

Fig: Example of Topology for IPv6

PC setting:

 IPv6_pc

Router setting:

 ipv6_router

Ping test:

ipv6_ping

                                Different kinds of IPv6 addresses

  • IPv6 Global Unicast AddressI

IP addresses are allocated by IANA (Internet Assigned Numbers Authority), through 5 RIRs (Regional Internet Registries), which are responsible for 5 different areas on the Earth.

ipv6_7

                                                          Regional Internet Registries

The current allocation of public IPv4 addresses is not sequential and continuous, meaning that a geographic region may acquire discontinuous ranges of public IPv4 address. This is due to the historical way of assignment and the insufficient public IPv4 addresses. E.g. For Macau region, it contains a large number of discontinuous, small address ranges, starting with 202.175.x, 27.x.y, 60.x.y, 113.x.y etc. This makes the aggregation of public IPv4 addresses very inefficient.

For IPv6, since it is a new deployment and there are huge numbers of IPv6 addresses. Huge enough to give each piece of sand on the Earth an IPv6 address. So, the assignment of public IPv6 addresses is more systematic. 

Currently only 1/8 of the IPv6 addresses are publicly assigned, which is :

2000::/3. What does it means? 

It means from 2000:: to 3FFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF

 

0010  0000  0000  0000  0000 0000 …. 0000 0000  

2      0     0    0   : 0000:0000:0000:0000:0000:0000:0000 

(Binary)

(Hexadecimal)

0011  1111  1111  1111  1111 1111 …. 1111 1111

3      F     F     F  : FFFF:FFFF:FFFF:FFFF:FFFF:FFFF:FFFF

(Binary)

(Hexadecimal)

And, currently, most of the assigned public IPv6 addresses starts with 2001::/16.

0010  0000  0000  0001  … … … … … … …… … … … … … … … … … … … … …

2     0     0     1   : … … … … … … …… … … … … … … … … … … … …

(Binary)

(Hexadecimal)

The IANA assigns address blocks to the five RIRs. The following table shows only a small portion of them. Usually, the IANA assigns address block with /23 prefix. 

2001:0200::/23

APNIC

 

2001:0400::/23

ARIN

2001:0600::/23

RIPE NCC

 

2001:1200::/23

LACNIC

2001:4200::/23

AFRINIC

   
ipv6_8

                                                                Fig: IANA

 

So, APNIC has got this block of IPv6 addresses:

 ipv_9

 Then, the APNIC assigns address blocks to ISPs.

e.g. APNIC may assign a block of addresses to ISPs like this : 

2001:02 55::/32  to ISPa

2001:02 66::/32  to ISPb 

So, ISPa gets a block of IP addresses as follows: 

ipv10

                           fig : ISPa gets a block of IP addresses

ipv11

                            fig: ISPa assigns blocks of IP addresses to different organization

In this point of view, Organization A is referred to as a Site.Now, the organization can freely use the remaining bits for its own, but, keeping 16 bits for Subnet ID. 

i.e. From 2001:0255:8888:0000::/64 to 2001:0255:8888:FFFF::/64 (The yellow portion is used as Subnet ID.)Then, for each subnet, there are 64 bits for hosts, all together, 2^64 hosts. This is called Interface ID and is used for identifying IPv6 host interface.  

ip_v_6_aa

                                                      fig: IPv6 host interface

 As one organization can have 65536 subnets, with each subnet having 264 hosts, this is far more than enough. So, no more subnetting is needed by the organization.

 The above resultant IPv6 addresses is publicly reachable in the Internet and is called :

1. IPv6 Global Unicast Address . It is similar to the IPv4 public addresses.

ip_7_v

                                                   fig: IPv6 Global Unicast Address

 2. IPv6 Link local (Unicast) Address   In IPv6, a network host will try to discover if there is any neighbor nearby.e.g. PC-A may send out a message like this:

ipv6_mu

fig: IPv6 Link local (Unicast) Address (PC-A may send out a message)

And PC-B may reply:

pc-reply

fig: IPv6 Link local (Unicast) Address (PC -B Reply)

You will notice that they are not using their Global Unicast address. Instead, they use a kind of IPv6 address called: “Link Local address”. In IPv6, Link Local address is used to communicate with neighbors in the same link or Layer 2 segment.

How is the Link Local address formed?

link local1

                                             fig: How is the Link Local address formed?

link local11

                                                        fig: How is the Link Local address formed?

The Link Local address is automatically generated, even though the interface has not been assigned with any IPv6 Global Unicast Address. IPv6 Link Local address is analogous to IPv4 Link Local address, in the range : 169.254.0.0/16. But, their usage is different. An IPv4 host will only get such an address when it is configured to use DHCP server to acquire IP address but no response from any DHCP server is got.

 

Thank you 

Momataj Momo