OSPFV2 Multi area Technology ( Configuration )

OSPFV2 Multi area configuration

OSPFV2 Multi area configuration

Router R1:

R1(config)#: interface GigabitEthernet0/0
R1(config-if)#ip address 10.1.1.1 255.255.255.0

R1(config)#: interface GigabitEthernet0/1
R1(config-if)#ip address 10.1.2.1 255.255.255.0

R1(config)#: interface Serial0/3/0
R1(config-if)#ip address 192.168.10.1 255.255.255.252
R1(config-if)#clock rate 64000

OSPFV2 Configuration Command:

R1(config)#router ospf 10
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.1.1.1 0.0.0.0 area 1
R1(config-router)#network 10.1.2.1 0.0.0.0 area 1
R1(config-router)#network 192.168.10.1 0.0.0.0 area 0
R1(config-router)#

Summarizing OSPF: 

R1(config)#router ospf 10

R1(config-router)#area 1 range 10.1.0.0 255.255.252.0
Router R2:

R2(config)#interface Serial0/3/0
R2(config-if)#ip address 192.168.10.2 255.255.255.252
R2(config)#

R2(config)#interface Serial0/3/1
R2(config-if)#ip address 192.168.10.5 255.255.255.252
R2(config-if)clock rate 64000

R2(config)#router ospf 10
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#network 192.168.10.4 0.0.0.3 area 0
R2(config-router)#
Router R3:

R3(config)#interface GigabitEthernet0/0
R3(config-if)# ip address 192.168.1.1 255.255.255.0

R3(config)#interface GigabitEthernet0/1
R3(config-if)# ip address 192.168.2.1 255.255.255.0
R3(config)#interface Serial0/3/1
R3(config-if)#ip address 192.168.10.6 255.255.255.252
Router(config)#hostname R3
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 192.168.10.6 0.0.0.0 area 0
R3(config-router)#network 192.168.1.1 0.0.0.0 area 2

R3(config-router)#network 192.168.2.1 0.0.0.0 area 2
R3(config-router)#end

Summarizing OSPF: 

R2(config)#router ospf 10

R2(config-router)#area 2 range 192.168.0.0 255.255.252.0

Verification and Troubleshooting Command:

R3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:38 192.168.10.5 Serial0/3/1
R3#
R3#
R3#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 1.1.1.1 [128] via 192.168.10.5, Serial0/3/1, ABR, Area 0, SPF 128
R3#
R1#show ip ospf interface

R1#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ – 00:00:30 192.168.10.2 Serial0/3/0
R1#

R1#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 3.3.3.3 [128] via 192.168.10.2, Serial0/3/0, ABR, Area 0, SPF 128
R1#
R1#show ip ospf database
OSPF Router with ID (1.1.1.1) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 239 0x80000002 0x00ffcf 2
2.2.2.2 2.2.2.2 164 0x80000004 0x00bc75 4
3.3.3.3 3.3.3.3 144 0x80000003 0x0004b1 2

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 284 0x80000001 0x00db72
10.1.2.0 1.1.1.1 284 0x80000002 0x00ce7d
192.168.1.0 3.3.3.3 139 0x80000001 0x007c6b
192.168.2.0 3.3.3.3 119 0x80000002 0x006f76

Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 288 0x80000003 0x008f8f 2

Summary Net Link States (Area 1)
Link ID ADV Router Age Seq# Checksum
192.168.10.0 1.1.1.1 284 0x80000001 0x00bbee
192.168.10.4 1.1.1.1 219 0x80000002 0x001451
192.168.1.0 1.1.1.1 134 0x80000003 0x00b9b3
192.168.2.0 1.1.1.1 114 0x80000004 0x00acbe
R1#

R1#show ip route ospf
O IA 192.168.1.0 [110/129] via 192.168.10.2, 00:04:37, Serial0/3/0
O IA 192.168.2.0 [110/129] via 192.168.10.2, 00:04:17, Serial0/3/0
192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks
O 192.168.10.4 [110/128] via 192.168.10.2, 00:06:03, Serial0/3/0
R2#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ – 00:00:31 192.168.10.1 Serial0/3/0
3.3.3.3 0 FULL/ – 00:00:34 192.168.10.6 Serial0/3/1
R2#

R2#show ip ospf border-routers
OSPF Process 10 internal Routing Table

Codes: i – Intra-area route, I – Inter-area route

i 1.1.1.1 [64] via 192.168.10.1, Serial0/3/0, ABR, Area 0, SPF 64
i 3.3.3.3 [64] via 192.168.10.6, Serial0/3/1, ABR, Area 0, SPF 64
R2#

R2#show ip ospf database
OSPF Router with ID (2.2.2.2) (Process ID 10)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 304 0x80000002 0x00ffcf 2
2.2.2.2 2.2.2.2 230 0x80000004 0x00bc75 4
3.3.3.3 3.3.3.3 209 0x80000003 0x0004b1 2

Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
10.1.1.0 1.1.1.1 349 0x80000001 0x00db72
10.1.2.0 1.1.1.1 349 0x80000002 0x00ce7d
192.168.1.0 3.3.3.3 204 0x80000001 0x007c6b
192.168.2.0 3.3.3.3 184 0x80000002 0x006f76
R2#

List of verification command:

R1# show Ip route OSPF
R1#show IP OSPF NEIGHBOR
R1#SHOW IP OSPF
R1#SHOW IP OSPF INTERFACE
R1#SHOW IP PROTOCOLS
R1#SHOW IP OSPF INTERFACE BRIEF
R1#SHOW IP OSPF DATABASE
R1#SHOW IP OSF BORDER-ROUTERS

Summarizing OSPF verification Command:

R3#show ip route ospf

10.0.0.0/22 is subnetted, 1 subnets

O IA 10.1.0.0 [110/129] via 192.168.10.5, 00:00:55, Serial0/3/1

192.168.10.0/24 is variably subnetted, 3 subnets, 2 masks

O 192.168.10.0 [110/128] via 192.168.10.5, 00:01:05, Serial0/3/1

R3#

Thank you

Momataj Momo

Practical : Simple OSPF Configuration

OSPF SIMPLE PRACTICS

OSPF Ttopology

Configuration Command on Router 0:
NETA>
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
NO shutdown
interface Serial0/3/0
ip address 172.16.1.1 255.255.255.252
clock rate 64000
NO shutdown
router ospf 10
network 192.168.1.0 0.0.0.255 area 0
network 172.16.1.0 0.0.0.3 area 0
Configuration Command on Router 1:
NETC>
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
NO shutdown

interface Serial0/3/0
ip address 172.16.1.2 255.255.255.252
NO shutdown

interface Serial0/3/1
ip address 200.100.50.1 255.255.255.252
clock rate 64000
NO shutdown

router ospf 20

network 172.16.1.0 0.0.0.3 area 0
network 192.168.2.0 0.0.0.255 area 0
network 200.100.50.0 0.0.0.3 area 0

Configurations Command on Router 3:
NETC>

interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
NO SHUTDOWN
interface Serial0/3/0
ip address 200.100.50.2 255.255.255.252
NO SHUTDOWN

router ospf 30
network 198.168.3.0 0.0.0.255 area 0
network 200.100.50.0 0.0.0.3 area 0
network 192.168.3.0 0.0.0.255 area 0

Thank you

Momataj Momo

Practice Skills Assessment – Packet Tracer (Module One Exam Solution )

You will practice and be assessed on the following skills:

  • Configuration of initial IOS device settings
  • Design and calculation of IPv4 addressing
  • Configuration of IOS device interfaces including IPv4 and IPv6 addressing when appropriate
  • Addressing of network hosts with IPv4 and IPv6 addresses
  • Enhancing device security, including configuration of the secure transport protocol for remote device configuration
  • Configuration of a switch management interface

Requirements by device:

  • Town Hall router:
  • Configuration of initial router settings
  • Interface configuration and IPv4 and IPv6 addressing
  • Device security enhancement or “device hardening”
  • Secure transport for remote configuration connections as covered in the labs.
  • Backup of the configuration file to a TFTP server
  • Administration Switch:
  • Enabling basic remote management by Telnet
  • PC and Server hosts:
  • IPv4 full addressing
  • IPv6 addressing
Skill Test Exam Solution

Fig : Topology (Skill Test Exam Solution)

ccna-1-skill-final-1

Step 1:

Design an IPv4 addressing scheme and complete the Addressing Table based on the following requirements. Use the table above to help you organize your work.

a. Subnet the 192.168.1.0/24 network to provide 30 host addresses per subnet while wasting the fewest addresses.

b. Assign the fourth subnet to the IT Department LAN.

c. Assign the last network host address (the highest) in this subnet to the G0/0 interface on Town Hall.

d. Starting with the fifth subnet, subnet the network again so that the new subnets will provide 14 host addresses per subnet while wasting the fewest addresses.

e. Assign the second of these new 14-host subnets to the Administration LAN.

f. Assign the last network host address (the highest) in the Administration LAN subnet to the G0/1 interface of the Town Hall router.

g. Assign the second to the last address (the second highest) in this subnet to the VLAN 1 interface of the Administration Switch.

h. Configure addresses on the hosts using any of the remaining addresses in their respective subnets.

Step 2: Configure the Town Hall Router.

a. Configure the Town Hall router with all initial configurations that you have learned in the course so far:

· Configure the router hostname: Middle

· Protect device configurations from unauthorized access with the encrypted password.

· Secure all of the ways to access the router using methods covered in the course and labs.

· Newly-entered passwords must have a minimum length of 10 characters.

· Prevent all passwords from being viewed in clear text in device configuration files.

· Configure the router to only accept in-band management connections over the protocol that is more secure than Telnet, as was done in the labs. Use the value 1024 for encryption key strength.

· Configure user authentication for in-band management connections.

b. Configure the two Gigabit Ethernet interfaces using the IPv4 addressing values you calculated and the IPv6 values provided in the addressing table.

· Reconfigure the link local addresses as was practiced in the labs. The IPv6 link-local Interface ID should match the IPv6 unicast Interface ID as is practiced in the labs.

· Document the interfaces in the configuration file.

Step 3: Configure the Administration Switch.

Configure Administration Switch for remote management.

Step 4: Configure and Verify Host Addressing.

a. Use the IPv4 addressing from Step 1 and the IPv6 addressing values provided in the addressing table to configure all host PCs with the correct addressing.

b. Use the router interface link-local addresses as the IPv6 default gateways on the hosts.

c. All hosts should be able to ping each other over IPv4.

Step 5: Backup the Configuration of the Town Hall Router to TFTP.

a. Complete the configuration of the TFTP server using the IPv4 addressing values from Step 1 and the values in the addressing table.

b. Backup the running configuration of Town Hall to the TFTP Server. Use the default file name.

Solution : 

Router>
Router>enable
Router#configure terminal
Router(config)#interface g0/0
Router(config-if)#ip address 192.168.1.126 255.255.255.224
Router(config-if)#description IT Department LAN
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#ip address 192.168.1.158 255.255.255.240
Router(config-if)#description Administration LAN
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#ipv6 unicast-routing
Router(config)#interface g0/0
Router(config-if)#ipv6 address 2001:db8:acad:A::1/64
Router(config-if)#ipv6 address FE80::1 link-local
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#interface g0/1
Router(config-if)#ipv6 address 2001:db8:acad:B::1/64
Router(config-if)#ipv6 address FE80::1 link-local
Router(config-if)#no shutdown
Router(config-if)#exit

Router(config)#
Router(config)#hostname Middle
Middle(config)#Enable secret class12345
Middle(config)#line console 0
Middle(config-line)#password cisconet2014
Middle(config-line)#login
Middle(config-line)#exit
Middle(config)#line vty 0 15
Middle(config-line)#password cisconet2014
Middle(config-line)#login
Middle(config-line)#exit
Middle(config)#line aux 0
Middle(config-line)#password cisconet2014
Middle(config-line)#login
Middle(config-line)#exit
Middle(config)#
Middle(config)#Banner motd “Authorized Access Only”
Middle(config)#security password min-length 10
Middle(config)#service password-encryption
Middle(config)#ip domain-name ccna.net
Middle(config)#username cisco secret cisconet2014
Middle(config)#crypto key generate rsa
The name for the keys will be: Middle.cisco.local
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

Middle(config)#line vty 0 15
Middle(config-line)#login local
Middle(config-line)#transport input ssh
Middle(config-line)#exit
Middle(config)#

—————————————–
Switch1 ip default gateway 192.168.1.158

—————————————–

Reception Host
default gateway FE80::1
default gateway 192.168.1.126

IP address 192.168.1.97/27
IPv6 address 2001:DB8:ACAD:A::FF/64

—————————————–

Operator Host

default gateway FE80::1
default gateway 192.168.1.126

IP address 192.168.1.98/27
IPv6 address 2001:DB8:ACAD:A::15/64

—————————————–

IT Host

default gateway FE80::1
default gateway 192.168.1.158

IP address 192.168.1.145/28
IPv6 address 2001:DB8:ACAD:B::FF/64

—————————————–

SERVER TFTP

default gateway FE80::1
default gateway 192.168.1.158

IP address 192.168.1.146/28
IPv6 address 2001:DB8:ACAD:B::15/64

—————————————–

Backup the Configuration of the Town Hall Router to TFTP.

Middle#copy running-config tftp
Address or name of remote host []? 192.168.1.146
Destination filename [Router-confg]? [Press Enter]

—————————————–

Momataj Momo

 

Skill Test in Packet tracer : Essential commands about your Network configuration

List of commands for Router and switch configuration you need to remember : 

Router # show running-config  will display active configuration from memory.

Router# show flash  flash memory is a special kind of memory on the router that contains the operating system image files , unlike regular router memory , flash memory continues to maintain the file image even after power is lost.

Router # show history the routers command line interface (CLI) maintains by default the last 10 commands you have entered in memory.

Router # show protocols use this command to view the status of the current layer 3 routed protocols running on your router.

Router # Show version This command will give you critical information such as : router platform type , operating system version , operation system last boot and file location , amount of memory , number of interfaces and configuration register.

Router # show clock will show you router clock

Router # show hosts will display a cached list of hosts and all of their interfaces IP addresses.

Router # show users will show a list of all users who are connected to the router.

Router # show Interfaces will give you detailed information about each interface.

Router # show IP interface brief this command will show brief description about interface. This command most used in troubleshooting. There may be three possible condition of status

UP: interface is up and operational  

Down : physical link is deleted but there are some problem in configuration  

Administratively down : port is disable by shut down command. ( default mode of any port on router )

Router # show IP route  This command will give a details about known route. Router will not forward packet if route is not shown here for that packet . Router’s routing decision is made by this routing table.

Router# Show controllers serial 0/0/0 most common use of this commands is to find out where the port is DCE and or DTE . If the port is DCE end then clock rate and bandwidth command will require . As you can see in Output that port is DCE.

Router # show IP protocols  using this command to know about running routing protocols . This will give the complete status about routing protocols likes on which interface its receiving updates and on which interface its broadcasting update what is time intervals.

Press enter to get back router prompt 

Router > You here now in user mode type “?” to view all the available command at this prompt.

Router >?

From privilege mode you can enter in configuration mode by typing configure terminal you can exit configuration mode type exit or <CTL> + Z

Router > enable

router # config terminal 

router <config> # exit

router # exit

To view all commands available from this mode type :  and press : Enter . This will give you the list of all available command for the router in your current mode. you can also use question mark after you have started typing a command.

For Example : If you want to use a show command but you don’t remember which one it uses ‘Show?’ will output all commands that you can use with the show command,

Router #show ?

switch# show arp (enable arp on the switch) For show arp interfacetype interface-instance form, the location node-id keyword and argument is mandatory for Bundle and VLAN-on-Bundle interfaces to indicate which location the cache entries for the bundle should be displayed. For physical interfaces, specifying the location node-id keyword and argument is optional since the interface can only exist on one node.

switch # show cdp neighbor (Enables CDP on the switch.) 

switch# show cdp neighbors (This example shows how to display all CDP neighbors)

switch# show cdp neighbors interface ethernet 1/29 (This example shows how to display the CDP neighbors for a specific Ethernet interface)

switch# show cdp neighbors interface ethernet 1/29 detail (This example shows how to display the detailed information of the CDP neighbors for a specific Ethernet interface)

switch# show cdp neighbors interface mgmt 0 (This example shows how to display the CDP neighbors for the management interface)

switch# show cdp neighbors interface mgmt 0 detail (This example shows how to display the detailed information of the CDP neighbors for the management interface)

switch# show cdp neighbors detail (this example shows how to display the detailed information of all CDP neighbors)

Cisco Discovery Protocol (CDP) or cdp enable::: 

To enable Cisco Discovery Protocol (CDP) on an interface, use the cdp enable interface configuration command. To disable CDP on an interface, use the no form of this command.

router # cdp enable

 router #no cdp enable

CDP Version 2 advertisements are diabled on the router:

Router#show cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Sending CDPv2 advertisements is enabled
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no cdp advertise-v2
Router(config)#end
Router#show cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Sending CDPv2 advertisements is not enabled
Router#

CDP is disabled on the Ethernet 0 interface only:

Router#show cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Sending CDPv2 advertisements is enabled
Router#config terminal
Router(config)#interface ethernet 0
Router(config-if)#no cdp enable

Router(config)# cdp log mismatch duplex The following example of the cdp log mismatch duplex command in global configuration mode enables the display of duplex messages from all Ethernet interfaces on the router.

Router# clear cdp counters

Router# show cdp traffic The following example clears the CDP counters. The show cdp traffic output shows that all of the traffic counters have been reset to zero.

Router # show file systems  Managing IOS configuration files.

router # copy running-config tftp Copy the running configuration file to the TFTP server

 

Thank you 

Momataj Momo